ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to access HP Storage Management Home from a remote host

Dermot1
Advisor

Unable to access HP Storage Management Home from a remote host

Host: Redhat 5.5 x86

Server version: CompaqHTTPServer/9.9 HP System Management Homepage/6.3.1.23 (Unix)
Server built: Jun 19 2011 22:11:24

 

 

I seem to have lost access to the hpsmh. It worked once but some time back it stopped working.  I have tried to update all the component parts but I can not access the Web GUI.

 

The http server is running:

hpsmh    11916 11912  0 10:52 ?        00:00:00 /opt/hp/hpsmh/sbin/hpsmhd -DSSL -f /opt/hp/hpsmh/conf/smhpd.conf
hpsmh    11917 11912  0 10:52 ?        00:00:00 /opt/hp/hpsmh/sbin/hpsmhd -DSSL -f /opt/hp/hpsmh/conf/smhpd.conf
hpsmh    11918 11912  0 10:52 ?        00:00:00 /opt/hp/hpsmh/sbin/hpsmhd -DSSL -f /opt/hp/hpsmh/conf/smhpd.conf
hpsmh    11919 11912  0 10:52 ?        00:00:00 /opt/hp/hpsmh/sbin/hpsmhd -DSSL -f /opt/hp/hpsmh/conf/smhpd.conf
hpsmh    11920 11912  0 10:52 ?        00:00:00 /opt/hp/hpsmh/sbin/hpsmhd -DSSL -f /opt/hp/hpsmh/conf/smhpd.conf

 

It looks like it will accept connections from the command line:

 

Spoiler
Spoiler

telnet localhost 2381
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
HEAD / HTTP /1.1
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>400 Bad Request</title>
</head><body>
<h1>Bad Request</h1>
<p>Your browser sent a request that this server could not understand.<br />
Reason: You're speaking plain HTTP to an SSL-enabled server port.<br />
Instead use the HTTPS scheme to access this URL, please.<br />
<blockquote>Hint: <a href="https://localhost:2381/"><b>https://localhost:2381/</b></a></blockquote></p>
</body></html>
Connection closed by foreign host.

 

 

 

But I cannot connect from a remote host. 

 

I have managed to get a connection using lynx but "System Management Homepage requires Javascript."

 

Does anyone know how I an enable remote access to the HP SMH?

 

Thanks in advance,

Dermot

 

 

 

 

 

2 REPLIES
Matti_Kurkela
Honored Contributor

Re: Unable to access HP Storage Management Home from a remote host

Your SMH may have been configured to accept connections from localhost only. This happens if you enable access restrictions on the SMH security tab but don't specify any allowed source addresses.

 

If that is the case, and you don't have a local GUI-based browser installed on the server (or cannot use X display forwarding to bring its window to your display), one possible solution is to use SSH port forwarding.

 

If you have a Linux/Unix workstation with GUI browser capability, the required command would be like this:

ssh -L 11111:localhost:2381 redhatserver

 

If you have a Windows workstation and are using PuTTY, go to Connection -> SSH -> Tunnels, type "11111" to "Source port" field, "localhost:2381" to "Destination" field, make sure "Local" pushbutton is selected, then click on Add. Then open the SSH connection to your Redhat server as usual.

 

Once the SSH connection is established, type the URL "https://localhost:11111" to your local browser.

 

What happens is:

1.) your SSH client (PuTTY or whatever) has set up a proxy on port 11111 on your local workstation. Any incoming traffic to it will be forwarded to the sshd at the remote end with instruction "pass this to localhost:2381". Any responses will be forwarded back the same way.

2.) your browser will initiate a HTTPS connection to port 11111 of localhost (i.e. your workstation), so it ends up being forwarded by the SSH client.

3.) the sshd at the remote end receives the forwarded traffic and passes it on to "localhost:2381" as seen by sshd, i.e. the SMH HTTPS port on the server.

4.) Your browser is likely to warn you about hostname mismatch with the SSL certificate, but the connection works!

 

When setting up a SSH port forwarding like this, remember that the destination specification is always interpreted by the sshd daemon at the remote end of the SSH connection; if you don't keep this in mind, the configuration won't seem to make any sense.

 

MK
Dermot1
Advisor

Re: Unable to access HP Storage Management Home from a remote host

Genius  idea.  I should have thought of that.

 

I managed to get in. It looks like I had restricted access to a range of IPs and we re-numbered our network a few months back.

 

Thanks for thats Matti.

Dp.