ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to install SLES on DL 380 g8

 
pier_t
Occasional Visitor

Unable to install SLES on DL 380 g8

Hi All,
I tried to install Linux on an DL380 Gen8p without success.

distributions were tested

SUSE  Enterprise Linux 11 sp 2 with HP Intelligent Provisioning
SUSE  Enterprise Linux 11 sp 2 with kISO
SUSE  Enterprise Linux 11 sp 3 with HP Intelligent Provisioning
Oracel Linux 6 u5

but in all cases it was impossible to complete the installation.
The error is always "can not find a usable hard drive "

System is  ProLiant DL380p Gen8 662257R-421
Intelligent Provisioning 1.60.217
Smart Array P420i   5.42
iLO 1:51

Can anyone help me?

2 REPLIES
Jimmy Vance
HPE Pro

Re: Unable to install SLES on DL 380 g8

Did you create an array on the Smart Array controller?




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
pier_t
Occasional Visitor

Re: Unable to install SLES on DL 380 g8

Solved!!!


it is probably a bug of the SLES installer  and Co.

It seems that the installer tries to load the module for the 2.6 kernel instead of the one for kenel 3

During setup phase the system tryed to install module hpsa with error "invalid module format"

 

modinfo hpsa show:
vermagic: 2.6.31.12-0.7-default SMP mod_unload modversions

 

while the module copied from a running SLES (installed on a vm using only the setup disk 1) gave this

vermagic: 0:11-3.0.76-default SMP mod_unload modversions

 

I did start the installation from SLES dvd and copied the correct module via USB stick,
depmod -a
modporbe hpsa
at this point is able to access the storage and to complete the installation.