ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to update vSphere host from 6.0 to 6.7 on HP BL460 G9 HW, due to vibs dependencies

 
Maghesh
Occasional Collector

Unable to update vSphere host from 6.0 to 6.7 on HP BL460 G9 HW, due to vibs dependencies

Unable to update vSphere host from 6.0 to 6.7 on HP ProLiant BL460c Gen9.

I have arounf 50+ host to migrate, Could i get custom image media which includes all the vibs!.. 

Also i don't to remove each vibs from each hosts to perform update< Command to remove vibs=> esxcli software vib remove -n <<vib-name>>>

Tried update using esxcli command:

[root@TSTWIN-ESX03:/vmfs/volumes/578dd967-f44bba92-11bd-b05adaba6370] esxcli software vib install -d "/vmfs/volumes/578dd967-f44bba92-11bd-b05adaba6370/VMware-ESXi-6.7.0-8169922-HPE-Gen9plus-670.10
.3.0.30-Jun2018-depot (1).zip"
 [DependencyError]
 VIB Emulex_bootbank_scsi-lpfc820_10.2.459.0-1OEM.500.0.0.472560 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.
 VIB Intel_bootbank_net-ixgbe_3.21.4-1OEM.500.0.0.472560 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.
 VIB QLogic_bootbank_scsi-bfa_3.2.5.0-1OEM.500.0.0.472560 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.
 VIB Mellanox_bootbank_net-mst_2.0.0.0-1OEM.510.0.0.472560 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.
 VIB QLogic_bootbank_net-qlcnic_5.3.191-1OEM.500.0.0.472560 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.
 VIB QLogic_bootbank_scsi-bfa_3.2.5.0-1OEM.500.0.0.472560 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.
 VIB QLogic_bootbank_net-qlcnic_5.3.191-1OEM.500.0.0.472560 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.
 VIB QLogic_bootbank_scsi-qla2xxx_934.5.45.0-1OEM.500.0.0.472560 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.
 VIB Intel_bootbank_net-ixgbe_3.21.4-1OEM.500.0.0.472560 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.
 VIB Mellanox_bootbank_net-mst_2.0.0.0-1OEM.510.0.0.472560 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.
 VIB QLogic_bootbank_scsi-qla2xxx_934.5.45.0-1OEM.500.0.0.472560 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.
 VIB Emulex_bootbank_scsi-lpfc820_10.2.459.0-1OEM.500.0.0.472560 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.
 Please refer to the log file for more details.

1 REPLY 1
HPSDMike
HPE Pro

Re: Unable to update vSphere host from 6.0 to 6.7 on HP BL460 G9 HW, due to vibs dependencies

First, I would start with the latest image (which just came out yesterday) 

https://my.vmware.com/web/vmware/details?downloadGroup=OEM-ESXI67-HPE&productId=742

Also, see a couple articles I found:

Wouldn't you use 'update' instead of 'install' in the esxli command? Here it is mostly filled out, just update your vmfs path. 

esxcli software profile update -p HPE-ESXi-6.7.0-Gen9plus-670.10.3.5.6 -d /vmfs/volumes/your_datastore/VMware-ESXi-6.7.0-9484548-HPE-Gen9plus-670.10.3.5.6-Sep2018-depot.zip

Make sure you update your blade firmware with the 2018.09 SPP (also just came out yesterday). It is best practice to have that run before running the new OS.



I work for HPE. The comments in this post are my own and do not represent an official reply from the company. No warranty or guarantees of any kind are expressed in my reply.

Accept or Kudo