ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

VCA showing un supporrted drivers AGAIN!!

 
Mat Sullivan
Advisor

VCA showing un supporrted drivers AGAIN!!

It would appear that the old issure with the VCA showing out of date drivers that are not required in the server has reared it's ugly head again, after running a full PSP install on several servers the VCA on these servers is reporting an out of date "HP StorageWorks Fibre Channel Adapter Kit for the x86 QLogic Storport Driver" this hardware is not installed in the server and when I try to update this driver it won't install for obvious reasons, how do I get round this?
8 REPLIES
KarloChacon
Honored Contributor

Re: VCA showing un supporrted drivers AGAIN!!

hi

yes there is a customer advisory of that and a workaround to fix it

http://urlao.com/vcafix

the advisory points out that the behavior has only been observed 2.1.8.780 which is include in PSP 7.8 I don't know if you installed PSP 7.8 in that case I think because there is a new version of VCA 2.1.9.790 (PSP 7.9) you can also try installing it to fix the issue
http://h18023.www1.hp.com/support/files/server/us/download/27546.html

regards
Didn't your momma teach you to say thanks!
KarloChacon
Honored Contributor

Re: VCA showing un supporrted drivers AGAIN!!

yes I think so

fix for the latest version

"Fixed a defect where Version Control Agent (VCA) incorrectly reports an inactive or obsolete Software and Drivers that are not actually required to be installed on ProLiant Servers, causing Overall status display as yellow (Degraded)"

In case you already have the latest follow the steps from the advisory

regards
Didn't your momma teach you to say thanks!
Mat Sullivan
Advisor

Re: VCA showing un supporrted drivers AGAIN!!

No Joy I'm affraid, I'm already running the latest PSP and the latest VCA on the problem servers.
Mat Sullivan
Advisor

Re: VCA showing un supporrted drivers AGAIN!!

See Attached JPG
James ~ Happy Dude
Honored Contributor

Re: VCA showing un supporrted drivers AGAIN!!

Hello Mat,

Apart from running on the latest version of PSP & VCA, that advisory also mentions about a work around, did you try that ?

Delete the built- in discovery module to automatically cause VCA to fall back to software inventory based on the foundation agent. If VCA is installed on the C drive, delete the "C:\hp\hpsmh\data\cgi-bin\vcagent\Discovery" folder and restart HP VCA service from Windows Service Manager. SNMP services must be installed and configured. Insight Management Agents must be installed and configured.

OR

Create an RDP job with the details outlined below and run the job from RDP. The steps shown below can be performed when the VCA is installed on the C drive. This solution is more useful if there are large number of servers affected with this issue. To create the RDP job, enter the following information in RDP:

* rem Fix VCagent discovery
* rmdir /s /q C:\hp\hpsmh\data\cgi-bin\vcagent\discovery
* sc stop cpqvcagent
* timeout /T 10
* sc start cpqvcagent

I hope, this still holds good. Try it !!

Regards.
Mat Sullivan
Advisor

Re: VCA showing un supporrted drivers AGAIN!!

Yes, this is the workaround I used to use before the problem was 'fixed' by the new VCA version, unfortunately it no longer works.
KarloChacon
Honored Contributor

Re: VCA showing un supporrted drivers AGAIN!!

Hi

have you tried unistalling VCA from Add/Remove programs, restart services, install it again ans restart services.

regards
Didn't your momma teach you to say thanks!
Mat Sullivan
Advisor

Re: VCA showing un supporrted drivers AGAIN!!

This problem is still evident and resists all attempts to fix it via workarounds etc... Is there any way to just manually uninstall this driver???