ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN issue with latest NIC Driver

SOLVED
Go to solution
Technology Helpdesk
Occasional Advisor

VLAN issue with latest NIC Driver

We currently have multiple VLANS setup on a Cisco 6500 and a DL360 g4p. When we upgrade to the latest support pack (7.90a) with firmware some of the VLANs are not accessible. We've tried this in two different environments and we get the same issue. The NIC model is a NC7782.

Has anyone seen this or does anyone have any documentation they could point me to on what may have changed on the latest NIC driver VLAN config wise?
29 REPLIES
James ~ Happy Dude
Honored Contributor
Solution

Re: VLAN issue with latest NIC Driver

Hello,

Try updating the NIC firmware ALONE,
then, upgrade the Drivers.

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=PSD_CO040408_CW01

{All this is after PSP 7.90}

Also, Disabling TOE Helps resolve MANY issues in NIC performance/Teaming Issues.

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1159651

Regards,
James.
Technology Helpdesk
Occasional Advisor

Re: VLAN issue with latest NIC Driver

James,

Thanks for the quick response. I don't see anywhere for me to disable the TCP Offload Engine under the NCU. Is there some place else or a command I should use?

Thanks again,

Travis
James ~ Happy Dude
Honored Contributor

Re: VLAN issue with latest NIC Driver

Hello Travis,

use the Command :

Netsh int ip set chimney DISABLED

Regards,
James.
James ~ Happy Dude
Honored Contributor

Re: VLAN issue with latest NIC Driver

Also refer :
http://support.microsoft.com/default.aspx?scid=kb;EN-US;927695

For Disabling RSS;

Regards,
James.
Technology Helpdesk
Occasional Advisor

Re: VLAN issue with latest NIC Driver

James,

Is there anything else I can try? I've tried both of those and I'm still not able to access some of the vlans.

Thanks again for the help.

Travis
James ~ Happy Dude
Honored Contributor

Re: VLAN issue with latest NIC Driver

Reading this Again... "When we upgrade to the latest support pack (7.90a) with firmware some of the VLANs are not accessible."

I hope U have Updated the FIRMWARE first, then the Latest Drivers; Then Apply the Latest NIC Teaming Software .. if any;

Which OS R u trying this ?
http://h18023.www1.hp.com/support/files/networking/us/download/24634.html
Or Go through the Documentation At
http://h18023.www1.hp.com/support/files/server/us/download/19958.html

Regards,
James.
Technology Helpdesk
Occasional Advisor

Re: VLAN issue with latest NIC Driver

James,

I applied the firmware and then the support pack which applies the latest drivers and NCU. This is for Windows 2003 R2 SP2 and I know that HP has had issues with SP2 and their NIC drivers.
James ~ Happy Dude
Honored Contributor

Re: VLAN issue with latest NIC Driver

Yes Travis, PSP does installs them;
However, It may be worth to install them separately; I have seen cases when Applying them separately solves issue; U might wanna try it too, in case u haven't :

NCU
http://h18023.www1.hp.com/support/files/server/us/download/27384.html

Broadcom drivers
http://h18023.www1.hp.com/support/files/networking/us/download/27387.html

Regards,
James.
HP_Sammy
Trusted Contributor

Re: VLAN issue with latest NIC Driver

Hi

Try this old driver and hopes it works

http://h18023.www1.hp.com/support/files/server/us/download/25512.html

Cheers :)
Blazhev_1
Honored Contributor

Re: VLAN issue with latest NIC Driver

Hi,

if the configuration is changed, you will be unable to connect to the VLANS with all tricks you make. I think that the driver changed the config of the NIC, not the VLAN, since it don't have acces to the VLAN(Switch). You can try to downgrade the driver and see if the problem is resolved.
If so , then there is 99% problem with the driver/his relation to the Cicso switch and you can open an elevation at HP suport...

Regards,
Pac
Massimiliano Fiorazzo
Occasional Advisor

Re: VLAN issue with latest NIC Driver

DL380 G4

Windows 2003 X64 installed with latest SmartStart CD (7.90)

When I add a Vlan to NC7782 with HP Network Utility I get an interface with:

MAC Physical Address: 00-00-00-00-00-00

and the server will comunicate with nobody !

can you tell me how to resolve this ?!?!?

thank you

max
Technology Helpdesk
Occasional Advisor

Re: VLAN issue with latest NIC Driver

James,

I'm back at the customers site and manually installing the firmware and drivers didn't fix the problem.

Pac,

From the looks of the config on a server still working it doesn't look like the updated driver changed the config. Obviously it changed something though. One thing I did notice is HP has separated the Large Send Offload and IPMI now with the new driver.

I am able to go back on drivers with the latest support pack. But the NCU won't work work and the only way to uninstall it is via the NIC and then it removes the 20 vlans we've got setup. So I'm not a big fan of that.

Also I've contacted HP and they shrug off as to just continue using your previous driver. The only problem is we've updated these servers to SP2 and now I have to get to the latest support pack to prevent random restarts and conflicts with certain drivers.

Thanks guys for all of your help. I honestly just wanted to make sure that we didn't setup our VLANS wrong on our switch, but they worked with the previous driver so in theory they should continue to work.

Re: VLAN issue with latest NIC Driver

Just wanted to give you the heads up that are you not alone with this issue.. IDENTICAL setup with the 6500 + DL360g4p.

If we disable any of the virtual VLAN NICs and re-enable it, the issue is resolved.

We're going to roll back to the v7.8 driver and see if that solves it.

-Craig
Technology Helpdesk
Occasional Advisor

Re: VLAN issue with latest NIC Driver

Craig,

Thanks...I was beginning to think I was all alone. So you were able to get it working if you disabled the VLAN and brought it back up? I'm willing to try that and that's not a bad work around if it works.

Thanks,

Travis

Re: VLAN issue with latest NIC Driver

Hi Travis,

Yes, simply disabling & re-enabling any of the virtual VLAN interfaces seems to resolve the issue... until you reboot the server, that is.

We're going to roll the driver back this weekend (I think..) and see what happens.

-Craig
Technology Helpdesk
Occasional Advisor

Re: VLAN issue with latest NIC Driver

Craig,

When we've tried the roll back idea we've had to recreate all of our 32 VLANS after we uninstall the NCU. Have you guys found a way to export the VLAN info and then reimport it?

Thanks,

Travis
Mi6t0
Trusted Contributor

Re: VLAN issue with latest NIC Driver

Hey there ;)

I think the previous idea for stopping TOE is really good and the driver works fine. Just go to network configuration utility - settings - advanced settings and remove the tick from TCP POffload engine.

Also - if you use teaming, make the settings on "transmit load balancing". One more thing - bios version is very important, the old one didn't allocate the ram properly. And sometimes the /PAE switch causes problems.

Greets!
Carlos Hernandez Barea
Occasional Advisor

Re: VLAN issue with latest NIC Driver

Hello.

Exactly the same issue with ProLiant BL20p G3. The workaround of disable-enable the interface works fine...until you reboot the server :-(

I have tried to disable TOE, but it seems that TOE is only availble if you have Teaming, not only VLAN's. Is it right?

Next I will downgrade the driver.

Regards.
Carlos Hernandez Barea
Occasional Advisor

Re: VLAN issue with latest NIC Driver

Hello.

The downgrade of the driver didn't fix the issue :-(

Maybe it would be a good idea downgrade also NCU?

Regards.
James ~ Happy Dude
Honored Contributor

Re: VLAN issue with latest NIC Driver

Hello Carlos,

TOE is not just or teamed NICs.
Please refer my Previous posts(above) for the Command to disable it.

Also, Did u update the Firmwares ?

Using an OLD NCU "may" resolve it .. "may not"

Regards,
James.
Technology Helpdesk
Occasional Advisor

Re: VLAN issue with latest NIC Driver

FYI...The old NCU will not work with the current driver. Actually it won't even open up because it complains about the NIC driver being out of date.
Carlos Hernandez Barea
Occasional Advisor

Re: VLAN issue with latest NIC Driver

Hello again.

When I execute the command

netsh int ip set chimney DISABLE

I get "The following command was not found" error....
James ~ Happy Dude
Honored Contributor

Re: VLAN issue with latest NIC Driver

Did u try "netsh int ip set chimney DISABLED" ??
Carlos Hernandez Barea
Occasional Advisor

Re: VLAN issue with latest NIC Driver

Yes.

It was a typo...