ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Version Control can't connect to VCRM

Jase4772
Regular Advisor

Version Control can't connect to VCRM

Hi,

I'm having to use VCA 8.41 at the moment as if I upgrade to 8.60 or 8.70 it fails to connect to the VCRM when I add the credentials. Is there any known issue's relating to this?

Very annoying not being able to get a green for the software status because of the tool to update everything not working.

Thanks
Jase
8 REPLIES
Jens Ey
Frequent Advisor

Re: Version Control can't connect to VCRM

Hi Jase,

what kind of error message do you get?
I'm using the current version of VCA w/o any problem with current versions of SMH and VCRM.

Jens
Bart_Heungens
Honored Contributor

Re: Version Control can't connect to VCRM

I assume you are not using Administrator anymore as user account since this is not supported anymore since a long time?

Is the account not locked? Did it work well before?

I am using also VCA/VCRM without any problems for years now...
--------------------------------------------------------------------------------
If my post was useful, clik on my KUDOS! "White Star" !
Jase4772
Regular Advisor

Re: Version Control can't connect to VCRM

Hi,

The error occurs just after entering all the VCRM name and credentials. We're using the same ones as before which is domain level.

With it working on 6.1.0.841 and 2.2.2.835 it seems weird that post updating to 6.3.0.870 (or 860) it just complains about "The specified repository, , is invalid or not reachable".

I've just performed a test on a working 835 VCA and then upgraded it to 870 using VC and now that errors appears.

I've updated the VCRM to the latest version incase that was the error.

Both boxes are W2K3 and the windows firewall is off.

Thanks
Jase
Jens Ey
Frequent Advisor

Re: Version Control can't connect to VCRM

OK, let's see.

1st guess: Name resolution. Try to ping the VCRM from the VCA server using its name. Maybe you have to use the FQDN? Also try to config the vca using the IP address of the VCRM server.

2nd guess: Access rights. Does the VCRM log shows anything suspicious? Has the service user of the vcrm (system in my case) access to the repository directory? I use a non-domain user with user-rights within VCA/VCRM. Best to check it using runas as the VCA client user and trying to access the files in the repository.
This user also has to be in the HP SIM Operators group!

Jens
Bart_Heungens
Honored Contributor

Re: Version Control can't connect to VCRM

With VCRM now upgraded to the latest version, is an older version of VCA still working?
Be sure that you are using SMH and VCA version 6.3.x, which was released after PSP 8.60
--------------------------------------------------------------------------------
If my post was useful, clik on my KUDOS! "White Star" !
Jase4772
Regular Advisor

Re: Version Control can't connect to VCRM

Hi guys,

Right then here's my results :-

- IP, name or FQDN no difference

- Using domain credentials which are in the local administrators group on the VCRM so full access to the repository. Same user being entered in the VCA and also the VCRM service runs as that user.

- Just updated a non working client manually to latest SMH and no difference.

- All 841 or older VCA's work

- VCA on the VCRM does work (annoyingly!)

- Nothing in the VCRM log when I try

Last one I'm not sure about as I've not seen it is the HP SIM Operators Group. I've only seen the Groups on the SMH Settings page so am I missing something here?


Thank you for your help with this.
Jase
Bart_Heungens
Honored Contributor

Re: Version Control can't connect to VCRM

VCRM/VCA should work even without HP SIM so I would not worry too much about that SIM Operators group now.

On the server where VCRM is installed can you create a local account version control with some password on it, put it in the local administrators group of that server and then try on the server with the latest VCA which does not work now?

What are the exact versions of the VCA and VCRM that you are using currently? So I can check with mysetup which works without problems...
--------------------------------------------------------------------------------
If my post was useful, clik on my KUDOS! "White Star" !
Jase4772
Regular Advisor

Re: Version Control can't connect to VCRM

Fixed!!!! After what seems an eternity of not working.

After rechecking the logs I noticed on the local log the version of the VCRM's SMH was in the URL string. Upgraded the VCRM's server to the latest SMH and it's all working now.

Moral of this thread, make sure the SIM server is upto date on all the components even if you don't think they're relavent!

Thank you everyone for your help. You certainly made me more focused on this and I'm sure that made a big help fixing it.

Thanks
Jase