ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

WinPE v2.1 (2008) and DL585G2 (NC371i)

Dave Behler
Frequent Advisor

WinPE v2.1 (2008) and DL585G2 (NC371i)

I'm trying to use the latest version of WinPE v2.1 (from Automated Installation Kit (AIK) for Windows Vista SP1 and Windows Server 2008) to deploy an OS image to a DL585G2. The NIC driver for the NC371i is not included with this version of WinPE from MS. I've tried loading the driver from SSSTK v1.9, from PSP8.0 (cp008421.exe) and HP NC-Series Multifunction Drivers for RIS/WinPE v8.7 and v9.0 all with the same results, the NIC driver never loads.

I did get the NC373i NIC driver to load for a DL385G2 using one of the sources from above, so I know how to integrate the drivers. I just can't seem to find a suitable one for the 585G2 (NC371i).

I did find this notice from HP that seems to document/acknowledge the issue and how to fix it.
" Notice: How to Add the HP NC-Series Multifunction Driver for Windows Server During Windows Preinstallation Environment (WinPE) Scripted Installation of Windows Server 2008"

Unfortunately, it doesn't shed any light as to where to get the drivers from. It makes mention of a ZIP file, but no link or location given.

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01425505&dimid=1012318972&dicid=alr_apr08&jumpid=em_alerts/us/apr08/all/xbu/emailsubid/mrm/mcc/loc/rbu_category_NoticeHowtoAdd/alerts

Any help would be greatly appreciated.
4 REPLIES
Arian van der Pijl
Regular Advisor

Re: WinPE v2.1 (2008) and DL585G2 (NC371i)

http://www.broadcom.com/support/ethernet_nic/netxtremeii.php

Can you try the generic RIS driver from Broadcom?
Dave Behler
Frequent Advisor

Re: WinPE v2.1 (2008) and DL585G2 (NC371i)

I knew that the Broadcom drivers existed, but didn't try them since they don't seem to apply to WinPE2.1 (which is based off of Windows 2008). I'll give them a try, but I don't understand why the drivers from the SSSTK v1.9, which are specifically for WinPE v2.1, don't work on a NC371i (DL585G2).
Dave Behler
Frequent Advisor

Re: WinPE v2.1 (2008) and DL585G2 (NC371i)

I finally got around to trying the Broadcom RIS drivers and same issue. With WinPEv2.1 (based on Windows 2008) on a DL585G2 it just seems as if some other system/bus device driver is missing that needs to load prior to the NIC.

I have a case open with HP, but so far no luck.
Dave Behler
Frequent Advisor

Re: WinPE v2.1 (2008) and DL585G2 (NC371i)

Problem resolved by HP Support.

It seems that this issue has been reported already and a BIOS version was release to fix it. According to my peers, they had already replicated the problem and then updated the BIOS and it resolved the issue.

I would like you to please try updating the BIOS to the newest version available. It can be downloaded by using this link:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=3219717&prodNameId=3288124&swEnvOID=1005&swLang=8&mode=2&taskId=135&swItem=MTX-d0953690551541efbcf1e58067

Upgrade DL585G2 system bios to 3.28.2008 and add the NIC drivers from the HP SSSTKv1.9 to WinPEv2.1.

Thanks to all who assisted with this problem.