ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Windows - Delayed Write Failed

 
Andrew Davenport
Frequent Advisor

Windows - Delayed Write Failed

Weird problem this one.
I have an HP Proliant ML350 G3 with a single Raid controller, 1 Raid 1 pair and 1 Raid 5 set on the controller.
The server was working fine until we put a fresh installation of Win2K3 on it.
Since the installation we have installed all the critical updates and backup software.
Now the server "seems" to run normally, that was until i tried to install PSP7.9 then it started throwing up delayed write failures all over the place and i have to reboot it to get it back operational again.
I can install PSP7.8 no problem, but PSP7.9 causes these errors to appear.
I suspect something else is amiss as the backup will not complete, reporting a hardware error but nothing more specific.
The event log shows disk errors, particularly repeated event ID 50 errors but HP Raid Diags say that all is fine with the controller and drives.
So it seems these errors occur only under heavy load, i.e. when backup is running or when the PSP7.9 install is scanning for installed components.
Does anyone have any ideas?
5 REPLIES
James ~ Happy Dude
Honored Contributor

Re: Windows - Delayed Write Failed

Hello Andrew,

A checklist:
1) did you use smartstart for the fresh installation ?
2) if yes, did you use the ERASE UTILITY ?
3) Are all the Firmwares Up-to-date ?
If no, download Firmware maintenance CD 7.9 from :
http://h18023.www1.hp.com/support/files/server/us/download/27783.html

Also, Refer:
http://support.microsoft.com/kb/816004
You also might want to reseat the Controller + Cache.

Regards,
James.
James ~ Happy Dude
Honored Contributor

Re: Windows - Delayed Write Failed

Oh, I also read(now) about the Backups not completing.

How is this done.... internal/external TAPE Drives? Or other media ?

Regards,
James.
Andrew Davenport
Frequent Advisor

Re: Windows - Delayed Write Failed

Hi,

Smartstart wasnt used as we didnt have a CD suitable for this server.
The install was done using the windows media and the latest drivers were used from the HP site.
Once installed the BIOS and RAID firmware were updated to the latest versions.
During the installation all partitions were deleted and fully formatted.
The tape drive is an Ultrium 2 LTO which is connected to a seperate SCSI controller, again the firmware and drivers on this controller are up to date.
I think the backup problem is just a symptom of the problems, something else underlies all this.
James ~ Happy Dude
Honored Contributor

Re: Windows - Delayed Write Failed

Andrew,
Try disconnecting the Tape; & monitor performance;

James.
Andrew Davenport
Frequent Advisor

Re: Windows - Delayed Write Failed

I have checked and reseated all cables internally, i have run the server up with the tape drive disconnected and again the same problems.
I have repeated event log entries as below.

Event Type: Error
Event Source: Disk
Event Category: None
Event ID: 11
Date: 17/10/2007
Time: 10:08:27
User: N/A
Computer: EXITWAY-SRV03
Description:
The driver detected a controller error on \Device\Harddisk0.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 04 04 68 00 01 00 ba 00 ..h....
0008: 00 00 00 00 0b 00 04 c0 .......
0010: 01 01 00 00 00 00 00 00 ........
0018: 00 00 00 00 00 00 00 00 ........
0020: 00 a0 b7 2c 00 00 00 00 .,....
0028: 74 7c 03 00 00 00 00 00 t|......
0030: ff ff ff ff 03 00 00 00 ....
0038: 40 00 00 84 02 00 00 00 @..?....
0040: 2a 20 0a 12 82 05 60 40 * ..?.`@
0048: 00 00 00 00 0a 00 00 00 ........
0050: 00 90 36 85 b0 da cd 85 .6??
0058: 00 00 00 00 40 98 b9 85 ....@??
0060: a0 1b f5 85 d0 5b 16 00 .?[..
0068: 2a 00 00 16 5b d0 00 00 *...[..
0070: 08 00 00 00 00 00 00 00 ........
0078: f0 00 04 00 00 00 00 00 .......
0080: 00 00 00 00 00 00 00 00 ........
0088: 00 00 00 00 00 00 00 00 ........

I am about to replace the Array controller with a spare and see if that makes a difference.

Thanks