ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

XR3000R UPS not recognized in Win2k3 Server Standard

James Schol
Occasional Visitor

XR3000R UPS not recognized in Win2k3 Server Standard

I have a XR3000R UPS that is running via serial on COM1. I am running a HP DL380 G4. I have installed the HPRPM 1.1 and its updates, but the server still does not recognize the UPS. I have the Serial Relay Agent (SRA) running.

Please help......
6 REPLIES
Mark Lenton_1
Occasional Contributor

Re: XR3000R UPS not recognized in Win2k3 Server Standard

Hi - No solution I'm afraid, but I am having a similar issue with some new hardware i.e. a R5500XR connected to a DL380G4 running Win2k3 Server Standard . The HPRPM does not recognise the UPS and the SRA is running, but is filling the application log with event id 57 error messages. I have disabled the iLO CLI as detailed in Customer Advisory EX050502_CW01 and have re-installed HPRPM a couple of times with no change in observed symptoms.

I currently have 5 new servers connected to this UPS and need to establish some control soon!! Any suggested fixes will be gratefully received ......
Brian_Murdoch
Honored Contributor

Re: XR3000R UPS not recognized in Win2k3 Server Standard

Hi,

There have been many issues with using the incorrect serial cable with new XR series UPS models.

The wiring between old (PRE-XR) and XR models is very different. The correct XR style comms cable has the following details.

Assembly Number - 201092-002
Spare Part - 204508-001

Please check the labels on the serial cable if possible to eliminate this as the cause.

Regards,

Brian
Marcus Martin
Frequent Advisor

Re: XR3000R UPS not recognized in Win2k3 Server Standard

Yup i have this working on 2 devices now but for the life of me i can not get it working on the 3rd.

I disabled the CLI on the ILO and have replaced the serial lead with the one specified above, I have unistalled the rack and power manager and then reinstalled but the SRA is still filling up the event logs.

What on earth is causing this? I have done everything but reset the UPS which will have to be a late night thing or a weekend deal.

Is it possible that the R5500XR COM port is in a locked stated and will not release its transmission until its either reset or unplugged.

Oh hold on the COM Card is supposed to be hot swappable i wonder if i just yank it out and push it back in again it will reset the COM ??? Hmmm might give that a go after lunch because other than that im all out of ideas.

Will report back when i take out the whole cabinet of servers lol.
Dan Nichols1
Occasional Advisor

Re: XR3000R UPS not recognized in Win2k3 Server Standard

I have this problem on three servers all DL360 G4p's, two have XR3000's attached and one has an XR5500 attached.

All have lost connection to the UPS and the SRA on each is logging Source "HP Serial Relay Agent" Event ID "57" Description "The event log file is corrupt".

The first UPS lost connection after 1 week and the last was two weeks from the original installation of RPM 1.1. All UPS devices were connected and functioning as expected until the lost connection.

A colleague of mine is having the same issue on another customer site.

I have disabled the CLI on the iLO; the server BIOS versions are all 14/02/2006.

Can anyone suggest a genuine fix for this problem?

Only one of the serial cables appears to have a part number visible and it is 128558-001 Rev. C Spare Part 154020-001 (GTM 0138).

Thanks,

Dan.
nurascorpio
Regular Advisor

Re: XR3000R UPS not recognized in Win2k3 Server Standard

Hi All,

Have you tried these:

Test the Serial COM Port using HyperTerminal or check for IRQ conflicts and status of the COM Port under System Information (Start / Run / winmsd)

If the UPS is listed in the device manager -Disable the UPS from device manager, then reboot the server and cancel the â new hardware found wizardâ , and then run the PSP and override the drivers installed.

Search and execute the file named â Cpqlpcc.exeâ . This will restore installation defaults for the HP Legacy Port Configuration

Erase the Non Volatile Memory or run a System ROM Update on the server

If the issue persists shut the server down, and remove the power cords from it. Leave the power completely disconnected for about 2 minutes, then plug it back in and boot it back up.

Regds
NS
nurascorpio
Regular Advisor

Re: XR3000R UPS not recognized in Win2k3 Server Standard

See if this helps !

http://h18007.www1.hp.com/support/files/server/us/download/24012.html - HP Uninterruptible Power System (UPS) Plug-and-Play Update for Microsoft Windows