HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

bonding does not work after restart

 
Fadia Almarei
Super Advisor

bonding does not work after restart

Dear All

i have RHEL 5.4 OS on DL580 G5 server , i try to cnfigure failover bonding on the built in network cards as the following
1-vi /etc/modprobe.conf
alias bond0 bonding
options bond0 mode=1 miimon=100
2- vi /etc/sysconfig/network-scripts/ifcfg-bond0
DEVICE=bond0
BOOTPROTO=none
ONBOOT=yes
NETWORK=192.168.122.0
NETMASK=255.255.255.0
IPADDR=192.168.122.118
USERCTL=no

3- vi /etc/sysconfig/network-scripts/ifcfg-eth4
DEVICE=eth4
MASTER=bond0
SLAVE=yes
USERCTL=no
BOOTPROTO=none
IPV6INIT=yes
IPV6_AUTOCONF=yes
ONBOOT=yes
4- vi /etc/sysconfig/network-scripts/ifcfg-eth5
DEVICE=eth5
MASTER=bond0
SLAVE=yes
USERCTL=no
BOOTPROTO=none
IPV6INIT=yes
IPV6_AUTOCONF=yes
ONBOOT=yes

i restart network service and every thing was OK , when i restart the server i could not reach the server , it does not work , what is the problem and how to solve it.
BR;
Fadia
fadia.marei
2 REPLIES
Michal Kapalka (mikap)
Honored Contributor

Re: bonding does not work after restart

hi,

this was a how-to for me as reference :

http://www.howtoforge.com/network_card_bonding_centos

my configuration :

its on IBM x3550 server CentOS 5.2

[root@bond-server etc]# more modprobe.conf
alias eth0 bnx2
alias eth1 bnx2
alias scsi_hostadapter aacraid
alias scsi_hostadapter1 ata_piix
alias scsi_hostadapter2 lpfc
alias bond0 bonding
options bond0 miimon=80 mode=5
###BEGINPP
include /etc/modprobe.conf.pp
###ENDPP


[root@bond-server network-scripts]# cat ifcfg-bond0
DEVICE=bond0
IPADDR=xxx.xxx.xxx.xxx
NETMASK=xxx.xxx.xxx.xxx
NETWORK=xxx.xxx.xxx.xxx
BROADCAST=xxx.xxx.xxx.xxx
GATEWAY=xxx.xxx.xxx.xxx
ONBOOT=yes
BOOTPROTO=none
USERCTL=no

[root@bond-server network-scripts]# cat ifcfg-eth[0-1]
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=none
USERCTL=no
MASTER=bond0
SLAVE=yes

DEVICE=eth1
ONBOOT=yes
BOOTPROTO=none
USERCTL=no
MASTER=bond0
SLAVE=yes

mikap
Gerardo Arceri
Trusted Contributor

Re: bonding does not work after restart

According to the following RH kbase , bonding options should be set using the BONDING_OPTS variable on the ifcfg-bondX file
http://kbase.redhat.com/faq/docs/DOC-7431

Also make sure the aliases for the different network cards are listed on /etc/modprobe.conf.
Here is an example for a BL460G6 Blade
alias eth0 bnx2x
alias eth1 bnx2x
alias eth2 tg3
alias eth3 tg3
alias eth4 tg3
alias eth5 tg3

We also blacklist the network driver modules so they are not loaded by udev by creating a file:
/etc/modprobe.d/networkfix
Which contains:

##NETWORKFIX##
##Do not allow common network card modules to autoload
blacklist bnx2x
blacklist bnx2
blacklist tg3
blacklist e100
blacklist e1000
blacklist e1000e
blacklist igb
blacklist vmxnet

That should fix your problem.
One more thing, whi are you using IPV6 options on your slaves when your MASTER is not configured for it ?