ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

can't directly install driver for 373i

Boutaleb
Occasional Advisor

can't directly install driver for 373i

Hi,

I have an issue when i try to install the driver Version: 4.6.17.0 (C) for NC373i, it always ask me to install Version: 4.6.16.0 first.
My cust want to install the last verion directly do you have any help ?

thx
4 REPLIES
Vulcan Maximus
Frequent Advisor

Re: can't directly install driver for 373i

KarloChacon
Honored Contributor

Re: can't directly install driver for 373i

this applies to you

HP NC-Series Broadcom 1GbE Multifunction Driver for Windows Server - First Update to Version 4.6.16.0 To Avoid Message "HP Virtual Bus Device Installation Requires a Newer Version. Version 4.6.16.0 is Required."


http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01684544&dimid=1046218472&dicid=alr_mar09&jumpid=em_alerts/us/mar09/all/xbu/emailsubid/mrm/mcc/loc/rbu_category_Notice(Revision)/alerts
Didn't your momma teach you to say thanks!
WJ Perry
Occasional Advisor

Re: can't directly install driver for 373i

Man... This is far from a clean upgrade on the majority of my test boxes, virtually undoable through SIM.

HP really need to come up with something better than this. 4.6.16.0 errors out halfway through the install but a reboot allows you to install 4.6.112.0... But then the whole entry in the Version Control Agent "HP NC-Series Broadcom 1Gb Multifunction Driver for Windows Server 2003" just goes away and no amount of rebooting seems to bring it back.

Anyone have a fix for this other than just not upgrading past 4.4.24.0?

Sometime the patch is worse than the problem it's fixing.
Rob Hotter
Occasional Advisor

Re: can't directly install driver for 373i

Hey Guys,

I've had a similar problems with NC373i cards though mainly when trying to upgrade using the Proliant Service Packs on my Blade BL460c's.

What i got it down to was the version of C:\windows\system32\drivers\Storport.sys. My Windows 2003 SP2 machine had v5.2.3790.3959.

This file has something to do with the way the NC373i HP Virtual bus device functions. After some searching I found this link to a newer Storport.sys file :

http://support.microsoft.com/kb/957910

In then end the steps i :

1) Upgraded the NIC firmware (via the BLade Online Firmware Bundle v1.60)
2) Installed the newer storport.sys file from Microsoft.
3) Rebooted.
4) Ran cp009681.exe (from http://h20000.www2.hp.com/bizsupport/TechSupport/
Document.jsp?objectID=c01684544〈=en&cc=u
s&taskId=101&prodSeriesId=428936)
5) Then installed the newer NIC driver and NCU (i did this via the Blade Online Firmware Bundle v1.60 - but you should be able to do it using the PSP install or manually).
6) Rebooted and all NIC software has been updated.

Hope this helps you out.
Cheers,
Rob