ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

clean w2K install on ml370 - need drivers for 431 array

Thomas Campitelli
Occasional Advisor

clean w2K install on ml370 - need drivers for 431 array

Howdy,

I would like to install Windows 2000 Server on my Compaq ML 370. I believe that I need to get a hold of the drivers for my Smart Array 431 card. I downloaded the drivers found here:

http://h18023.www1.hp.com/support/files/server/us/download/17750.html

When upacked, these drivers do not have a txtsetup.oem file and I cannot install Windows 2000 where I want to. Here's some info on my system:

PIII 1000 Mhz
1 GB RAM
Smart Array 431 Controller
System Disks (RAID 1)
2 x 8 GB
Data Disks (RAID 5)
3 x 18 GB

When I go install W2K Server, it sees the RAID 5 array as one big 36 GB disk and nothing else. I don't want to touch my RAID 5 array (altough it is nicely backed up). I want to install W2K on the mirrored array (or just one of the disks in the mirror).

What am I missing here? Do I need different drivers? I'm almost positive that I have no other SCSI cards in my system, although NT4 is not nearly as informative as 2000 in that regard. I assume that I need drivers that I can put on a floppy and load in the beginning of a W2K install by pressing F6. However, I can see my RAID 5 array so perhaps I do not need 3rd party drivers.

Do I need to "unmirror" my RAID 1 array in NT prior to installing 2K?

I have a SmartStart 5.50 CD, however it is not very clear what I can do with it. If possible, I would like to do as generic of an installation as possible and not use the Compaq utilities. However, I am open to suggestions.

Thank you in advance for any advice.

Sincerely,

Tom
13 REPLIES
Thomas Campitelli
Occasional Advisor

Re: clean w2K install on ml370 - need drivers for 431 array

Never mind. I was able to find the correct driver for the Integrated SCSI controller on the motherboard. I am able to see the other hard disks now. Sorry about that.

Tom
Agnes Lim
Occasional Advisor

Re: clean w2K install on ml370 - need drivers for 431 array

Hi Tom,

I think I am in the same situation as you.

I have been looking around for the Win2k drivers, mainly the preinstall drivers in the beginning of a W2k install by pressing F6, but to no avail.

It seems to me that you have managed to install W2K on your 431 array controller.

Please advise how I can do so. If it is possible, can you advise how I can download the driver file as well.

Thanks in advance.

Agnes
Thomas Campitelli
Occasional Advisor

Re: clean w2K install on ml370 - need drivers for 431 array

Howdy Agnes,

I have an ML370, so the link I provide might not work for your machine. However, here is what happened to me.

I have 5 hard drives in my server. Three of them hang off of my 431 card in a RAID 5 array. Then, I have two mirrored disks that are plugged into the integrated SCSI controller on my machine. I wanted to install the OS on to those disks. At the time I did not realize that the two disks on my SCSI controller were mirrored through the OS, not through my RAID card.

When I went to install Win 2K, it recognized my RAID 5 array as one big disk, but not my other two drives. In order to see them I downloaded the HP ProLiant 32-Bit SCSI Controller Driver for Windows 2000/Windows Server 2003 that can be found here:

http://h18023.www1.hp.com/support/files/server/us/download/17320.html

Those drivers will fit on a floppy and allow you to install the OS on to the other disks by pressing F6 at startup.

That may not quite answer your question, however. It sounds like you want to install onto your RAID Array. Windows 2000 server recognized the 431 card and had drivers ready to go. You may not need extra drivers to install onto your RAID array.

Let me know if that helps. I also recommend installing the support pack after you have the OS installed. It's awfully big, but I found it to be useful.

http://h18023.www1.hp.com/support/files/server/us/download/19613.html
Thomas Campitelli
Occasional Advisor

Re: clean w2K install on ml370 - need drivers for 431 array

One other thing. Should you need them, the Smart Array 431 drivers can be found here:

http://h18023.www1.hp.com/support/files/server/us/download/17750.html

Tom
Terry Hutchings
Honored Contributor

Re: clean w2K install on ml370 - need drivers for 431 array

The previous link has the correct drivers, but they don't have the txtsetup.oem file. Without this file it's not possible to use this driver during a Windows 2000 install.

Windows 2000 will not allow you to specify an updated driver during the install if Windows already includes this driver (on the CD). I'd recommend looking at MS kb article Q225125.
The truth is out there, but I forgot the URL..
Agnes Lim
Occasional Advisor

Re: clean w2K install on ml370 - need drivers for 431 array

Howdy Tom, Howdy Terry,

Thanks for your reply.

Terry, I have tried to check out the article that you recommended, but the URL have been removed.

The machine I am setting up is also a ML370 (PIII 800 MHz). I am having the problem exactly as what Terry has described. The W2K installation 'hangs' at 'Setup is starting Windows 2000'. It is impossible to continue with the installation.

Currently, my machine is running on system bios P17 (08/24/2000), SCU version 2.58A, and the firmware for the array 431 controller is Rev A, v1.02, cache size 2MB. It has been enabled as the first boot controller.

How do I proceed to install my W2K server ? Any ideas ?

Thanks again in advance.

Agnes
Victor Pendlebury
Valued Contributor

Re: clean w2K install on ml370 - need drivers for 431 array

Hi

As W2000 was developed on Proliant hardware, the cpqarry and cpqarry2 drivers are part of the W2000 cd ; so you don't need to specify any drivers during install

The driver available on the web is only an updated version

Vic
Agnes Lim
Occasional Advisor

Re: clean w2K install on ml370 - need drivers for 431 array

Hi,

if that's the case, any idea why my installation 'hangs' at the screen ?

Any suggestion

Cheers,
Agnes
Agnes Lim
Occasional Advisor

Re: clean w2K install on ml370 - need drivers for 431 array

One more thing, I have 2 logical drives set up on the 431 controller. Could that have pose any problems ?

Agnes
Agnes Lim
Occasional Advisor

Re: clean w2K install on ml370 - need drivers for 431 array

Hi,

After lots of tries and finally got it successfully installed. Just like to share with all how.

First of all, must upgrade the system bios. This can be found in
http://h18000.www1.hp.com/support/files/server/us/download/17423.html

Next, download the firmware maintenance CD, found from
http://h18004.www1.hp.com/support/files/server/us/subscription/ssdownloads.asp

Burnt the ISO file into a CD. It's a bootable CD. Boot from the CD and update the ROM flash offline for Smart Array 431 Controller.

Start the server from the SmartStart CD. I am using version 5.4. Perform an erase on the System Utility. Reboot the server again with the SmartStart CD still inside. A configuration wizard to guide you through the rest of the setup.

Hope these information helps.

Remember to update all drivers again from
http://h18000.www1.hp.com/support/files/server/us/locate/20_1119.html#58

Cheers,
Agnes
Thomas Campitelli
Occasional Advisor

Re: clean w2K install on ml370 - need drivers for 431 array

Howdy Agnes,

I'm glad to hear that you were able to get it working. Enjoy W2K.

Tom
robbieruss
Occasional Visitor

Re: clean w2K install on ml370 - need drivers for 431 array

Thank you, Thank you thank you, i started my task on friday evening, a 'simple' hard drive upgrade and now on Sunday afternoon i am only getting anywhere.

I am running 3 seagate 36Gb HDD's on a Compaq(comkak)ML 370 800Mhz Server.

When i booted off Windows Server 2000, after installing all this smartstart stuff about 38 times, it would not recognise the Scsi controller and give me a 'no hard disks found' error.

although windows 2003 Server found the drivers.

after finding this article and downloading the windows 2000\2003 server drivers for the scsi controller within 10 minutes i was ready to kiss the screen!
Marcin Piaszczynski
Occasional Contributor

Re: clean w2K install on ml370 - need drivers for 431 array

Hello all
I have similar problem.
I have ML350 with 4 disks 18GB SCA pluged to SmartArray431.
When i try to install W2K Server automatic (or manual) with SmartStart5.50, instalation hangs (anyway it looks like hang) when i finish configuring my arrays.
I configure 2 mirrors (disk 0 & 1, and disk 2 & 3) and when i click finish mouse icon change and all diodes blinking on all disks (on disk 0 disk led flash constantly rest leds blinks). I found info in internet then disk remirrors at this time and it can take some time. But i wait long time (many hours) and nothing change...
All bios are upgraded to last version from firmware CD.
What wrong i do ??