ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

conrep utilitly not able to read/set "Memory Interleaving" for bl465c G7

mwong
Occasional Contributor

conrep utilitly not able to read/set "Memory Interleaving" for bl465c G7

It seems like I am not able to get a proper reading of what the "Memory Interleaving" value is set at from the conrep utility (tried 3.30 from stk 8.70 and 3.40 from stk 9.40). I tried applying/re-applying a setting, but it didn't work. In the BIOS(F9), it is set to "No Interleaving", but I'll try to set it to "Channel Interleaving" in conrep and it won't happen. I have verified this by returning to the BIOS and also running STREAM benchmark. The bencharmk is half as slow when "No Interleaving" VS "Channel Interleaving". The conrep section for this is "AMD_Memory_Interleaving". Anybody have suggestions or confirm? I'd like to be able to tell which of our systems has "No Interleaving" and then set it to "Channel Interleaving" without having to go into the BIOS manually.

Hardware: bl465c g7 BIOS: 12/08/2012
conrep: 3.40 from the 9.40 STK (also tried 8.70 STK)
The "Power Management Options => Advanced Power Management Options => Memory Interleaving" is set to "No Interleaving"
However, running conrep, it does not detect this.
$ ./conrep -s -f /tmp/conrep.out
conrep 3.40 - SmartStart Scripting Toolkit Configuration Replication Program
Copyright (c) 2007-2012 Hewlett-Packard Development Company, L.P.
System Type: ProLiant BL465c G7
ROM Date : 12/08/2012
ROM Family : A19
Processor Manufacturer : AMDXML System Configuration : conrep.xml
Hardware Configuration : /tmp/conrep.out
File contains global platform restrictions
Global Restriction: [minimumconrepversion ] OK
Platform check: : [ProLiant DL120 G7 ] no match
: [ProLiant ML110 G7 ] no match
: [ProLiant DL3 ] no match
: [ProLiant ML3 ] no match
: [ProLiant DL5 ] no match
: [ProLiant ML5 ] no match
: [ProLiant DL7 ] no match
: [ProLiant DL9 ] no match
: [ProLiant BL ] match
: [ProLiant XW ] no match
: [ProLiant WS ] no match
: [ProLiant SE ] no match
: [ProLiant SL4 ] no match
: [ProLiant SL3 ] no match
: [ProLiant SL2 ] no match
: [ProLiant DL160 Gen8 ] no match
: [ProLiant SL160 Gen8 ] no match
: [ProLiant SL140 ] no match
: [ProLiant WS460c Gen8 WS Blade] no match
: [ProLiant MicroServer Gen8] no match
Saving configuration data to /tmp/conrep.out.CONREP Return code: 0
$ grep Interleaving /tmp/conrep.out
<Section name="Memory_Interleaving" helptext="Modifies the level of interleaving for which the memory system will be configured. Typically, higher levels of memory interleaving result in maximum performance, but reducing interleaving level may result in power savings.">Full_Interleaving</Section>
<Section name="AMD_RevF_Node_Interleaving" helptext="Allows the enabling/disabling of node interleaving on AMD platforms.">Disabled</Section>
<Section name="AMD_Memory_Interleaving" helptext="Sets the memory channel mode on AMD G7 servers.">Channel_Interleaving</Section>
[miwong@gram1234 /tool/sysadmin/.package/hp-smartstart-scripting-toolkit/9.40/utilities]$
Trouble Shooting:
OS Revision: RHEL5 U8
Product Version:
SAR:

 

Doing conrep -l -f /tmp/conrep.out does not apply "Channel Interleaving"