ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

dl380 g4 problem with RIS- help not pxe problem

shane_62
Occasional Advisor

dl380 g4 problem with RIS- help not pxe problem

I am now almost bald ripping out my hair. If anyone has an idea please let me know what I can do.

So this is what is going on...

I am able to use RIS with g2’s and g3’s only. When I try and use RIS on a dl380 G4, I keep getting one problem after another.

1. When booting up the RIS Client to PXE it would just loop back and reset itself.
I corrected that by using the Firmware Update manager 7.20, and updating the array controller and everything else.

2. getting past the PXE boot I get to the ‘Client Install Wizard’
I enter in all the required username and PW
I select the Operating system I want.
And then received the “you do not have the right nic drivers” and would then terminate the install.
I corrected that by adding the drivers to RIS and adding that $oem$\$1\drivers\nic stuff etc. as I have seen posted in this forum.

3. I am now stuck at a new point. When the RIS client boots up in PXE, I am able to connect to my image.
After it connects it goes to the warning about how the harddrive data will be deleted.
I select ok, and hit enter to begin the setup.

The setup screen appears and install some stuff.
It then sits on “setup is starting windows” and then directs me to this message “Setup did not find any Hard disk drives installed in your computer.
Make sure any hard disk drives are powered on and properly connected to your computer, and that any disk-related hardware configuration is correct. This may involve running a manufacturer-supplied diagnostic or setup program.”

I grabbed my smartstart cd and my drive is there. I also see the array boot up fine.

Can someone please help me or have any ideas? 

Other thins I have tried is building an image from a g4 and putting it on the RIS server. I recieve
8 REPLIES
Tarek Kawach
Honored Contributor

Re: dl380 g4 problem with RIS- help not pxe problem

Shane:

HP came up with firmware upgrade for the Smart array 6i controller to fix these issues.
there is a customer advisory on this.

and you may want to check out this Thread.

http://forums1.itrc.hp.com/service/forums/bizsupport/questionanswer.do?threadId=707961

Make sure that the firmware for the 6i and the server are uptodate. server should be at 12/02/2004 and 6i should be at v. 2.36.

Tarek.
Hey, look a light at the end of the tunnel.
Tarek Kawach
Honored Contributor

Re: dl380 g4 problem with RIS- help not pxe problem

Certain ProLiant Servers Exhibit Unexpected Behavior When Installing An Operating System Using Microsoft Remote Installation Service (RIS)
customer advisory EM041123_CW01 revision 2
released January 2005

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=PSD_EM041123_CW01

--
ProLiant DL380 G4 (3.4GHz+), Microsoft Windows Server 2003 http://h18000.www1.hp.com/support/files/server/us/locate/69_5561.html
--

Systems ROMPaq Firmware Upgrade Diskette for HP ProLiant DL380 G4 (P51) Servers
version 4.02 P51-12/02/2004 (12 Jan 05)http://h18000.www1.hp.com/support/files/server/us/download/22313.html
--

Offline ROM Flash for SmartStart Maintenance: ROM Update Utility - Smart Array 6i
version 2.36 A (26 Jan 05)http://h18000.www1.hp.com/support/files/server/us/download/22339.html
-- you will need the firmware maint. cd to do this update.
Firmware Maintenance CD
version 7.20 (14 Feb 05)http://h18000.www1.hp.com/support/files/server/us/download/22489.html
--
Firmware Upgrade Image for the HP Integrated Lights-Out Management Controller
version 1.70 A (16 Feb 05)http://h18000.www1.hp.com/support/files/server/us/download/22541.html
--

These are all the updates.
- Make sure that the port and controller where drives are connected is set to the first boot controller in the Bios (F9).

Tarek.
Hey, look a light at the end of the tunnel.
shane_62
Occasional Advisor

Re: dl380 g4 problem with RIS- help not pxe problem

Thanks for the reply. However, my problem is not fixed :(

I knew about the firmware, array 6i update and already updated using the newest firmware update manager v7.20

The problem I am having is that is is not seeing my Harddrive to install the os onto.

now if i just throw in a serer2k3 cd into this sever and boot up.. all is well. I dont get it.

am I missing something?
Jason_417
Occasional Visitor

Re: dl380 g4 problem with RIS- help not pxe problem

Just wondering if you have come up with a solution. I am having the exact same things happen on 3 DL360 G4's.
Kai-Uwe Schurig
Valued Contributor

Re: dl380 g4 problem with RIS- help not pxe problem

Hi,

have a look at this very active thread:

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=728971

Seems that you had to include the HP driver for the Smart Array 6i in the right way. A lot of other hints are also in this thread.

Kai-Uwe
shane_62
Occasional Advisor

Re: dl380 g4 problem with RIS- help not pxe problem

Jason,

I was able to make this work.

Here is what I did.

Updated array controler with firmware maintenance cd 7.20

created \$oem$\textmode folder and put in these drivers.

cpqcissm.cat
cpqcissm.inf
cpqcissm.sys
txtsetup.oem
cpqcisse.inf
cpqcisse.sys
cpqcisse.dll
cpqcisse.cat

created $oem$\$1\divers\storage

put in these drivers:
cpqcissm.cat
cpqcissm.inf
cpqcissm.sys
txtsetup.oem
cpqcisse.inf
cpqcisse.sys
cpqcisse.dll
cpqcisse.cat


I edited the ristndrd.sif and added the following:

[Unattended]
UnattendMode = FullUnattended
OemPreinstall = yes
OemPnPDriversPath = \Drivers\storage


[MassStorageDrivers]
"Smart Array 6i, 641, 642, 6400, 6400EM Controllers" = OEM

[OEMBootFiles]
cpqcissm.cat
cpqcissm.inf
cpqcissm.sys
cpqcissm.oem
cpqcisse.inf
cpqcisse.sys
cpqcisse.dll
cpqcisse.cat

hope this helps...

also make sure there is not a cpqcissm.dll file in your txtsetup.oem

if there is remove it.

ie. it should look like something like this:

[Files.scsi.0046]
driver = d1,cpqcissm.sys,cpqcissm
inf = d1,cpqcissm.inf
catalog = d1,cpqcissm.cat

i hope this helps.

-Shane
shane_62
Occasional Advisor

Re: dl380 g4 problem with RIS- help not pxe problem

everyhting works fine for me... see last post
Michael Agee_1
Occasional Visitor

Re: dl380 g4 problem with RIS- help not pxe problem

Shane,

I am currently trying to setup RIS installations with the dl380's. I was wondering if you could send me your configuration files pointing to drivers and what not so I could use them.

Mickey

General Dynamics