ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

failed raid5 array on a Smartarray 221

Ayman Altounji
Valued Contributor

failed raid5 array on a Smartarray 221

Hello,

Having spent the last 18 hours on this problem, I've come to pick some brains:

Server is a dual processor Proliant 1850R w/ SmartArray 221 Array controller, 4x 18.2 GB drives in a RAID 5 configuration. Running NT4.0 Server.

NT BSOD'd on me after a routine reboot to remove NetBIOS. At this point, NT would not boot up in any way shape or form. Tried using NT Repair Disks.

What I want to know is that the data on this array "should" still be accessible, however, Compaq SmartStart insists on booting off of the array, even though there is a standalone SCSI drive w/NT installed and functional. What I want to do is boot of the standalone drive, and then have the array as a bunch of data drives.

Booting off the array gives "non-system disk" error. (no standalone drive connected)

Booting w/array and standalone gives a BSOD. I can't give error reports, since these servers are in the Netherlands, I'm in Toronto, and the techncians didn't grab it for me.

Is there an option in the BIOS to disable booting the Array (or controller) and then having NT pick it up in the standalone configuration? I've tried leaving the drives un-connected from the array, booting off the standalone and then connecting the drives to the controller.

Compaq's Array Configuration utility picks up the array card, but not the drives after this instance (which I suppose is understandable, though these are supposed to be hotswappable drives).

Or is there an easy way to determine if my data is still intact on the array? I have a gut feeling it's not, with the technicians having clicked OK a few times too many in a few weird spots, but nothing I can do about that.

Anyhelp would be much appreciated: it's probably something simple, and given the amount of time I've worked on these along with my remote hands, we're hoping it is.

Mike Kalinovich