ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

how to use Linux Magic SysRq with ILO 2

blentes
Frequent Advisor

how to use Linux Magic SysRq with ILO 2

Hi,

 

i'd like to use the linux Magic SysRq with an ILO network adapter. I managed to get the virtual serial port running. While googleing a lot, i found that the SysRq has to be initiated in a serial connection with ESC-Ctrl-B (break) and afterwards the key for the desired SysRq function. But that doesn't work. When i press ESC-CTRL-B quickly sucessively and afterwards one key for the desired SysRq-function, e.g. 'S' for sync, i always get a help message for SysRq:

 

Sep 9 16:30:20 sunhb58820 kernel: [ 6948.509447] SysRq : HELP : loglevel(0-9) reBoot Crash terminate-all-tasks(E) memory-full-oom-kill(F) kill-all-tasks(I) thaw-filesystems(J) saK show-backtrace-all-active-cpus(L) show-memory-usage(M) nice-all-RT-tasks(N) powerOff show-registers(P) show-all-timers(Q) unRaw Sync show-task-states(T) Unmount force-fb(V) show-blocked-tasks(W) dump-ftrace-buffer(Z)

 

Using any letter like Q or T or W does not work. I always get the help message, just numbers to change the loglevel (0-9) work.

 

Any help appreciated

 

 

Bernd

 

P.S. IT's a ILO 2 adapter, firmware 2.25, host ML 350 G6, system ROM 07/02/2013

2 REPLIES
derick_souza
Frequent Advisor

Re: how to use Linux Magic SysRq with ILO 2


I used /proc/sys/kernel/sysrq-key which is usually mapped to 84 (PrintScreen) and remapped it to 109 (PgDown). Here have the steps :


1) Add "kernel.sysrq-key = 109 into /etc/sysctl.conf


2) Modify the kernel value with
# echo 109 > /proc/sys/kernel/sysrq-key


3) Map PgDown+p to a hot key in the Virtual Console for ILO (to test that SysRq is working)


Hope It helps.

blentes
Frequent Advisor

Re: how to use Linux Magic SysRq with ILO 2 - SOLVED

Hi,

 

i solved it. All the pages i found while googleing didn't help me. They all said i have to use the break signal and afterwards the specific key for the desired function. But it didn't work. Finally i selected "Remote Console" ==> "Settings" ==> "Hot keys" and mapped the existing hotkeys (CTRL + key) to the desired function of Magic SysRq.

Everything is fine now :-))

 

Bernd