ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

hp-OpenIPMI & hp-health

SOLVED
Go to solution
bossprecision
Occasional Visitor

hp-OpenIPMI & hp-health

When I attempt to install hp-health in CentOS 5 64bit it requires hp-OpenIPMI. I can not get that to install. The output I get is below

Preparing... ########################################### [100%]
1:hp-OpenIPMI ########################################### [100%]
This kernel requires a rebuild. Seeking source files
Basic source files appear to be installed. Investigating further.
The file: /lib/modules/2.6.18-92.1.22.el5/build/.config
does NOT exist. There must be a Linux kernel
'.config' file with IPMI enabled to build this
package.
Unknown Linux Distribution - No Source to build
Please read the Licence Agreement for this software at

/opt/hp/hp-OpenIPMI/COPYING
and
/opt/hp/hp-OpenIPMI/hp-OpenIPMI.license

By not removing this package, you are accepting the terms
of the included licenses.

The man page, hp-OpenIPMI(4), describes how to enable and use
the hp-OpenIPMI device drivers.

How would I setup the kernel.config file for this requirement?
3 REPLIES
Matti_Kurkela
Honored Contributor
Solution

Re: hp-OpenIPMI & hp-health

Welcome to the ITRC Forums!

In practice, to use the hp-OpenIPMI and hp-health drivers with RHEL/CentOS 5, you must install the "kernel-devel" package and make sure its version matches the "kernel" package you're currently using.

The "kernel-devel" package contains the necessary .config file for building kernel modules (which is what the hp-OpenIPMI package wants to do).

MK
MK
bossprecision
Occasional Visitor

Re: hp-OpenIPMI & hp-health

Matti,
Thank-you that was it. I thought I had Yummed all the kernel packages in. Somehow I missed the one that mattered.

Steve
Nikolay I Kolev
Occasional Visitor

Re: hp-OpenIPMI & hp-health

Hi,

I have the same problem on Debian. What package do I need to install? Thanks in advance.