ProLiant Servers (ML,DL,SL)
Showing results for 
Search instead for 
Did you mean: 

hp-ilo installation problem (vermagic difference)

Occasional Visitor

hp-ilo installation problem (vermagic difference)

I successfully installed hp-ilo package on Red Hat Enterprise Linux ES release 4 (Nahant Update 5) with kernel 2.6.9-55.ELsmp.

But when I tried to install the same package on Red Hat Enterprise Linux ES release 4 (Nahant Update 7) with kernel 2.6.9-78.0.13.ELsmp it produced error about version magic mismatch between hp-ilo module and kernel

Jul 9 16:28:49 cb-wcc-2 kernel: hpilo: version magic '2.6.9-78.0.13.ELsmp SMP 686 REGPARM 4KSTACKS gcc-3.2' should be '2.6.9-78.0.13.ELsmp SMP 686 REGPARM 4KSTACKS gcc-3.4'

Thereâ s difference in gcc version used during compilation for module hp-ilo and for kernel.

How can I install hp-ilo on kernel 2.6.9-78.0.13.ELsmp?

I note that in package hpilo module has next version magic strings:

[root@cb-wcc-2 tmp]# modinfo /opt/hp/hp-ilo/bin/2.6.9-78.0.13.ELsmp/hpilo.ko

â ¦

vermagic: 2.6.9-78.0.13.ELsmp SMP 686 REGPARM 4KSTACKS gcc-3.2

it produces error â as kernel 2.6.9-78.0.13.ELsmp has version magic '2.6.9-78.0.13.ELsmp SMP 686 REGPARM 4KSTACKS gcc-3.4' and I cannâ t install module on this kernel.

But for old kernel

[root@cb-wcc-2 tmp]# modinfo /opt/hp/hp-ilo/bin/2.6.9-55.ELsmp/hpilo.ko

â ¦

vermagic: 2.6.9-55.ELsmp SMP 686 REGPARM 4KSTACKS gcc-3.4

module was compiled the same version magic as in kernel and thereâ s no such problem.

Where can I take module for 2.6.9-79.0.13.ELsmp kernel with correct version magic? Or may this problem be solved by another way?

Piotr Kierklo
Occasional Visitor

Re: hp-ilo installation problem (vermagic difference)

Hi. I had to do the following, as I had two compilers - old gcc3.1 on /usr/local/bin and newer gcc 4.1 (the same which was used to compile the kernel) on the /usr/bin.

/usr/local/bin was earlier in the PATH when I installed the .rpm for the first time.

Error in dmesg was:

hpilo: version magic ' SMP 586 REGPARM gcc-3.4' should be ' SMP 586 REGPARM gcc-4.1'



So I did this:


umount  /usr/local


# echo  - force the driver to rebuild


# echo  - force to reinstall the package
rpm -Uvh --force /usr/src/packages/RPMS/i586/hpilo-kmp-bigsmp-9.0.0_2.6.16.46_0.12-183.sles10.i586.rpm


# echo  - insert the module again
modprobe hpilo


# echo -- start the driver
/etc/init.d/hp-ilo start

And the driver loaded

Piotr Kierklo, sysadmin