ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

hponcfg - Error: Unable to locate SSL library

Mike_FR
Occasional Visitor

hponcfg - Error: Unable to locate SSL library

hi guys,

 

i have just installed the hponcfg 5.2 (tested with 5.3 as well...) on my dl360 G10 server and I am receiving this error when launching the app :

 

<server-name>:~ # hponcfg
HP Lights-Out Online Configuration utility
Version 5.2.0 Date 10/27/2017 (c) 2005,2017 Hewlett Packard Enterprise Development LP
Error: Unable to locate SSL library.
Install latest SSL library to use HPONCFG.

<server-name>:~ # rpm -qa | grep -i hp
hponcfg-5.2.0-0.x86_64
hp-health-10.80-1855.22.sles12.x86_64

<server-name>:~ # rpm -qa |grep -i ssl
perl-Net-SSLeay-1.81-40.1.x86_64
perl-IO-Socket-SSL-2.025-89.1.noarch
openssl-1.0.2j-60.30.1.x86_64
libopenssl1_0_0-1.0.2j-60.11.2.x86_64

 

any ideas ?  Runnning on the SUSE 12sp3

dl360r-02:~ # uname -a
Linux <server-name> 4.4.82-6.3-default #1 SMP Mon Aug 14 14:14:02 UTC 2017 (4c72484) x86_64 x86_64 x86_64 GNU/Linux

3 REPLIES
Ragz
Occasional Visitor

Re: hponcfg - Error: Unable to locate SSL library

Hi Mike_fr,

 

Please do let me know what version of iLO firmware are you using. If you are at firmware level 1.30, please downgrade to 1.20 as I have seen it work. Meanwhile HPE is working to see what can be the issue.

 

Regards.

Jimmy Vance
HPE Pro

Re: hponcfg - Error: Unable to locate SSL library

 Fresh install of SLES 12 SP3 on a DL380 Gen10. Installed hponcfg-5.2.0-0.x86_64.rpm  Using both iLO firmware 1.20 and 1.30   hp-health isn't supported on Gen10 platforms, use amsd

linux:~ # hponcfg -g
HP Lights-Out Online Configuration utility
Version 5.2.0 Date 10/27/2017 (c) 2005,2017 Hewlett Packard Enterprise Development LP
Firmware Revision = 1.20 Device type = iLO 5 Driver name = hpilo
Host Information:
                        Server Name: dl380
                        Server Serial Number:
linux:~ # hponcfg -g
HP Lights-Out Online Configuration utility
Version 5.2.0 Date 10/27/2017 (c) 2005,2017 Hewlett Packard Enterprise Development LP
Firmware Revision = 1.30 Device type = iLO 5 Driver name = hpilo
Host Information:
                        Server Name: dl380
                        Server Serial Number: 

I started out with the default kernel 4.4.73-5, then used zypper to update the system and now have kernel 4.4.140-94.2

I didn't grab a version list before the update, but here is the ssl files output after the update

linux:~ # rpm -qa | grep -i ssl
perl-IO-Socket-SSL-1.962-3.1.noarch
libopenssl1_0_0-1.0.2j-60.30.1.x86_64
perl-Net-SSLeay-1.64-3.2.x86_64
openssl-1.0.2j-60.30.1.x86_64
python-pyOpenSSL-16.0.0-4.3.4.noarch
libopenssl1_0_0-32bit-1.0.2j-60.30.1.x86_64

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
VI_2
Occasional Contributor

Re: hponcfg - Error: Unable to locate SSL library

Hi! 

On windows 2008r2 i have this problem with SSl dll too...

 

ERROR:  Unable to locate 'HPSSLConnection.dll'. Please place a copy of the .dll in the current working directory.  The .dll may be found in the directory the utility was extracted to.