ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

i8042prt / PS/2 Compatible Mouse missing, issue with KVM

AJStevens
Occasional Contributor

i8042prt / PS/2 Compatible Mouse missing, issue with KVM

I have two ML110 G4 servers, running Windows SBS 2003 R2 SP2 and Windows Server 2003 R2 SP2, and an ML370 G5 Server also running Windows SBS 2003 R2 SP2.

I have a 4 port Belkin desktop KVM, when I switch to the ML110's the mouse goes mental, completely erratic and pressing buttons. When I flick to the ML370, it's fine.

I noticed on the 370 it has both HID-Compatible and PS/2 Compatible entries for Mouse and Keyboard in Device Manager, whereas on the ML110's they ONLY have the HID-Compatible Keyboard and HID-Compatible Mouse entries.

It doesn't appear that the i8042prt.sys driver/service is installed, and I can't find the driver to force an install from "Add new hardware".

If I look in the i386 folder I do see a i8042prt.SY_ file, but I don't understand why it's not installed/loaded on the ML110's but has on the 370.

I suspect if I can get these driver entries on the ML110's the Mouse will work correctly via KVM.

I've plugged a PS/2 Keyboard and mouse into one of the ML110's directly and rebooted, yet it still doesn't detect them and install the drivers, it seems happey to control them via the "HID" entry (the mouse and keyboard work fine).

This is irritating as I want to get the mouse working correctly via the KVM.

Any ideas how to install/load the i8042prt.sys service/driver and get it to detect or force an install of the PS/2 compatible drivers into Device Manager?