ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

iLO 4 AD authentication issue

wjbrauck
Visitor

iLO 4 AD authentication issue

I'm running DL360 Gen 8 servers with iLO4  and iLO firmware 2.10

 

I'm attempting to set up the iLO to authenticate with Active Directory.

 

I've installed certficates on the AD and have tried both 1024 bit and 2048 bit keys.  I get the same failure results.

 

I've configured the iLO to use Directory Default Schema,  Kerberos Athentication is disabled,  Local user accounts are enabled.

 

Under Administration>User Administration I've configured a Directory group with the DN of the group that will have access rights.  All access rights are checked.

 

Under Administration>Security>Directory  I've entered the IP of the AD server, the Directory Server LDAP port is set to 636, I've configured a Directory User Context with the OU path to the group containing the admin users.

 

I've tried setting these by hand and also using the Directories Support for Proliant Mangement Processors app to set the configuration.

 

when I run the test Settings  function, I get the following

   Connect Using SSL                        Warning          Certficate Subject mismatch, verify OK...

   Directory User Contexts              Success

   Directory Administration login   Success

   Connect to Directory Server       Success

   Ping Directory Server                   Success

   Directory Server DNS Name       Success

   LOM object exists                         Failed               unable to confirm LOM object N/A in directory

                                                                                              should this run if not using Kerberos authentication?

   User Authorization                        Failed              LDAP bind failed; invalid Credentials

   User Authentication                      Failed              Unable to authenticatetest user [invalid credentials]

  Bind to directory Server                Failed              LDAP bind failed; invalid Credentials

 

Since the credentials are valid, my assumption is that something is wrong in the either the user context or directory group definition.   Since the values were generated automatically using the Directories Support for Proliant Mangement Processors app and selecting the desired groups from the tree, I'm at a loss how to proceed.

 

Suggestions welcomed!

 

   Walt

 

1 REPLY
GirishKG
Occasional Visitor

Re: iLO 4 AD authentication issue

This video would help you
https://www.youtube.com/watch?v=rGnm2Kc10J0

 

-Girish KG