ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

iLO Powershell SSL Certificate cmdlet 2.x.x.x not working on Gen9 iLO4, but 1.x.x.x cmdlet does

 
Highlighted
NWMrTim1
Occasional Visitor

iLO Powershell SSL Certificate cmdlet 2.x.x.x not working on Gen9 iLO4, but 1.x.x.x cmdlet does

Hello all,

I have gond round and round on this all over the Internet trying to find a solution, some say "this may work" or I have not tried.  Here's what I can tell you I HAVE tried

I downloaded the HP iLO Powershell cmdlet (version 1.5.0.0.) and wrote a script to cycle through a list of iLOs and get SSL Certificate Requests, and create CSRs to get signed, etc.  Everything works great.

Then we got some Gen 10 servers in, and in the interest of staying up to date, I downloaded the HPE ILO CMDlets (version 2.2.0.0) mostly because of enhanced iLO configuration capabilities,  The idea was to run one script to configure the iLO and then run another to create the CSR, and save those to a file (like ILONAME.CSR) to be signed, etc.

I noticed that the "new" version of the script was not producing CSR files, but the old one still was.  Effectively, when I set $ILOCSR = Get-HPiLOCertificateSigningRequest -Server $server -credential $creds....  and they type: $ilocsr in the shell, I can see output, the $ilocsr.STATUS_TYPE is "OK", and the field $ilocsr.CERTIFICATE_SIGNING_REQUEST contains the data of the CSR that gets written to a file.

When I do the exact same thing with the Version 2.x.x.x (version 2.2.0.0) of the powershell cmdlets, using this:  $ILOCSR = Get-HPEiLOCertificateSigningRequest -Connection $connection the fields returned are different.   $ilocsr.STATUS is "OK" and $ilocsr.CertificateSigningRequest is BLANK.

the iLO4 has the 2.70 version of the Fimrware, and I've seen (you need 2.60 or higher, "this was fixed in 2.61", that kind of response, but I can tell you for sure, I tried both versions from the same desktop to the same iLO trying with boht versions, and the version 2.x.x.x did not work to the iLO4 with F/W 2.70, but the 1.x.x.x version of the powershell cmdlet DID work.

Thanks.

2 REPLIES 2
Highlighted
NWMrTim1
Occasional Visitor

Re: iLO Powershell SSL Certificate cmdlet 2.x.x.x not working on Gen9 iLO4, but 1.x.x.x cmdlet does

can you free up my Original Username too??  (NWMrTim)

Highlighted
AmRa
HPE Pro

Re: iLO Powershell SSL Certificate cmdlet 2.x.x.x not working on Gen9 iLO4, but 1.x.x.x cmdlet does

Hi 

We have received update that there is an issue in CSR generation with custom fields using iLO cmdlets 2.X and respective team are working towards fixing the bug.

As a workaround you can use previous release of iLO cmdlets i.e., 1.5.x version.

I am an HPE Employee

Accept or Kudo