ProLiant Servers (ML,DL,SL)

iLO did not detect the Agentless Management Service when this page was loaded. To view a full set of

 
SOLVED
Go to solution
lucianol
Occasional Advisor

iLO did not detect the Agentless Management Service when this page was loaded. To view a full set of

 HPE custom image Vsphere 7.0.2 installed on my DL 380 GEN 10 server .New servers ,and this ams error .
I tried  to download the ams package from HPE site 
https://support.hpe.com/hpesc/public/swd/detail?swItemId=MTX_521550eda2644e46af366f9a9b#tab1
and reinstall it ,nothing happenes .I get this :
[root@sxxxx/tmp] esxcli software component apply -d /tmp/amsdComponent_700.11.6.10.4-1_17206321.zip
Installation Result
Components Installed:
Components Removed:
Components Skipped: amsdComponent_700.11.6.10.4-1
Message: Host is not changed.
Reboot Required: false
Any ideas ? how i can solve this ?

13 REPLIES 13
mysy
Valued Contributor

Re: iLO did not detect the Agentless Management Service when this page was loaded. To view a full se

If you use the HPE oem version ESXI image to install , it already include the AMs and ILO driver package. you could check package from your esxi management web page.

My server will show AMS is OK after esxi complete boot up. Durning the ESXI boot process ,it will show AMS not load/install.

https://www.hpe.com/us/en/servers/hpe-esxi.html 

lucianol
Occasional Advisor

Re: iLO did not detect the Agentless Management Service when this page was loaded. To view a full se

Hi,
Yes I know that, but my server ILO5 shows that the AMS is not installed, and yes I use the HPE ESXI 7.0.2 custom image,
What’s more strange ,the same server if I install ESXI 6.7 the AMS is recognized .
This are 5 new Dl380 g10 servers .All servers up to date :
I use the latest HPE VUP for ESXI 7 and the HPE esxi 7.0.2 image (build 17630552)
Also I opened a case in VMware ,because the LCM doesn’t work ,and they explained me that the LCM cannot communicate with the AMS agent ,and to check with HPE .
SanjeevGoyal
HPE Pro

Re: iLO did not detect the Agentless Management Service when this page was loaded. To view a full se

Hello,

HPE Agentless Management is an architecture in which the hardware management capabilities run on the iLO hardware, independent of the host OS and processor and it replaces the OS based Agents.

It allows HPE ProLiant servers to collect and deliver hardware and other server management information to other management consoles.

Refer the Article for more information:

https://psnow.ext.hpe.com/doc/4aa6-6053enw?jumpid=in_lit-psnow-red

 

Download files for AMS are as follows :

https://support.hpe.com/hpesc/public/swd/detail?swItemId=MTX_521550eda2644e46af366f9a9b

 


I am a HPE Employee

Accept or Kudo

lucianol
Occasional Advisor

Re: iLO did not detect the Agentless Management Service when this page was loaded. To view a full se

Hi,
I know that ,but how this info exactly help me with my brand new dl380 gen 10 server with an ESXI OS 7.0.2 we’re the AMS agent it is not working ?
And also the ILO5 doesn’t recognize it +Oneview ,that needs the AMS and SUT agents so he can deploy updates .
I think I just discovered a new Bug related to AMS on vsphere 7.0.2...
lucianol
Occasional Advisor

Re: iLO did not detect the Agentless Management Service when this page was loaded. To view a full se

Found the problem-> the AMS daemon that is checking the ISCSI software initiator

When the ISCSI agent is installed on the ESXI host , the AMS daemon crash every 10 sec .Apparently i found  a bug so i opened a case and waiting for HPE for a solution 

SanjeevGoyal
HPE Pro

Re: iLO did not detect the Agentless Management Service when this page was loaded. To view a full se

Hello,

I would suggest, you have to log a proper case with HPE, and share the appropriate logs for further analysis.


I am a HPE Employee

Accept or Kudo

lucianol
Occasional Advisor

Re: iLO did not detect the Agentless Management Service when this page was loaded. To view a full se

Hi,

HPE ticket was opened in HPE 3 weeks ago, with no findings whatsoever. My findings 3 days ago were sent to HPE and they approve them. Now I'm waiting for a solution from them, apparently a new recompiled  AMS package that will work with ISCSI and Vsphere 7 . Too bad that I (customer)  discovered this, especially that Vsphere 7 is up there for 1 year already.

This issue with the ISCSI Software initiator and AMS agent is up there from Vsphere 7.0.0.

 

 

lucianol
Occasional Advisor

Re: iLO did not detect the Agentless Management Service when this page was loaded. To view a full se

Update from HPE :
BUG was found in the ams agent .
Vsphere 7 + iscsi connection combo cause one of the ams service daemon to crash .
Waiting for L3 solution 

mabehp
Occasional Visitor

Re: iLO did not detect the Agentless Management Service when this page was loaded. To view a full se

Hello lucianol,

 

Did HPE provide you with a fix (or a new update ofcourse)? We are experiencing the same issue.