ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

iLO2 is set up but I'm unable to log in.

iLO2 is set up but I'm unable to log in.

Hello,

   I'm somewhat of a rookie at this. I purchased a used Proliant ml350 G6 to help me learn so I have something here at home to work with.

I followed the instructions I found for setting up iLO3 on a G7 server. Disabling splash screen, going into F8 and set up (even though I have iLO2 on a G6)

DNS/DHCP disabled, ip/dns/gateway all set correctly

I set a password and then saved info and power cycled the server.

I'm able to access the iLO2 ip address from any device on my network but all I get is an error screen 

 

Establishing a secure Integrated Lights Out session with host is unnamed at 192.168.0.113

Note: When the 'Security Alert' panel is displayed, you must select 'Yes' to accept the certificate to access Integrated Lights-Out.

Does this refer to the messages doing boot up?

I'll attach a couple of screenshots and will reply with info as requested.

4 REPLIES

Re: iLO2 is set up but I'm unable to log in.

error message.

Torsten.
Acclaimed Contributor

Re: iLO2 is set up but I'm unable to log in.

The ILO is trying to switch from http to https.

The ILO firmware is veeeery old, AFAIR the protocol used is now blocked by chrome and others.

You should first try to update ILO firmware, then test again, may internet explorer gives a warning, but works.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   

Re: iLO2 is set up but I'm unable to log in.

Hi Torsten,

   I've tried a couple different ways to update the firmware via this website. Is there somewhere else I can look? Heck, I've even tried checking google for driver download links that aren't questionable. haha. 

https://support.hpe.com/hpsc/swd/public/detail?sp4ts.oid=1008862657&swItemId=MTX_c1566edd86c44a1189d6b30af7&swEnvOid=4184#tab3

Every time, it stops the install because my O/S isn't supported.

I have tried troubleshooting for compatibility but it won't let me install. 

What if I isntall Server 2008 as a virtual machine, might i be able to update them then?

Jimmy Vance
HPE Pro

Re: iLO2 is set up but I'm unable to log in.

You can download the HPE Lights-Out XML Scripting Samples for Windows or Linux and send the  firmware update from another system using the iLO XML scripting tools

HPE Lights-Out XML Scripting Sample for Windows
https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_98ea081cc4bf42c08044b65f39

HPE Lights-Out XML PERL Scripting Sample for Linux
https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_76bfa460792d4f7cbc0aac234e

You will need to extract the iLO firmware image from the EXE or RPM file to upload via the XML scripting.  The is an example script called Update_Firmware.xml included in the above packages

<!--         RIBCL Sample Script for HP Lights-Out Products          -->
<!--Copyright (c) 2015 Hewlett-Packard Development Company, L.P.     -->

<!-- Description:  This is a sample XML script to update the         -->
<!--               firmware of following devices:                    -->
<!--                 Integrated Lights-Out 4 (iLO 4)                 -->
<!--                 Integrated Lights-Out 3 (iLO 3)                 -->
<!--                 Integrated Lights-Out 2 (iLO 2)                 -->

<!-- NOTE:  You will need to replace the USER_LOGIN and PASSWORD     -->
<!--        values with values that are appropriate for your         -->
<!--        environment and you will need to change the value of the -->
<!--        IMAGE_LOCATION to point to the new binary firmware image -->
<!--        you wish to use for the firmware update.                 -->
<!--        The Unit ID light flashes when the server is engaged in  -->

<!--        an activity that can not or should not be interrupted    -->
<!--        (such as updating iLO firmware or an active Remote       -->
<!--        Console session).  The Unit ID light should flash while  -->
<!--        this script is updating the firmware.                    -->
<!--        The Lights-Out device will automatically reset itself to -->
<!--        have the new firmware take effect at the end of the      -->
<!--        firmware flash.                                          -->

<!--        Use CPQLOCFG.EXE ver 4.20 or greater for iLO2 and        -->
<!--        HPQLOCFG.EXE ver 1.00 or greater for iLO 3 and iLO 4     -->
<!--        with this script.                                        -->

<!--        This script was written for iLO 4 firmware version 1.01  -->
<!--        release.                                                 -->

<!--        See "HP Integrated Lights-Out Management Processor       -->
<!--        Scripting and Command Line Resource Guide" for more      -->
<!--        information on scripting and the syntax of the RIBCL     -->
<!--        XML.                                                     -->

<!--        Firmware support information for this script:            -->
<!--            iLO 4 - All versions.                                -->
<!--            iLO 3 - All versions.                                -->
<!--            iLO 2 - All versions.                                -->

<RIBCL VERSION="2.0">
   <LOGIN USER_LOGIN="adminname" PASSWORD="password">
      <RIB_INFO MODE="write">
         <!--  Firmware support information for next tag:            -->
         <!--  iLO 4 - All versions. For servers with TPM enabled.   -->
         <!--  iLO 3 - All versions. For servers with TPM enabled.   -->
         <!--  iLO 2 - 1.70 and later. For servers with TPM enabled. -->
         <TPM_ENABLED VALUE="Yes"/>
<!--NOTE: iLO 4 - 1.30 and above.                                    --> 
<!--         Change UPDATE_RIB_FIRMWARE (for flashing iLO firmware)  -->
<!--         with UPDATE_FIRMWARE for flashing ROM and CPLD firmware.-->
         <UPDATE_RIB_FIRMWARE IMAGE_LOCATION="D:\D_drive_backup\Images\ilo4_100_p90.bin"/>
      </RIB_INFO>
   </LOGIN>
</RIBCL>

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!