HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

iLO4 1.51 scripting, can't enable syslog

 
SOLVED
Go to solution
yom_
Occasional Collector

iLO4 1.51 scripting, can't enable syslog

Hi,

 

I'm trying to enable syslog on a iLO4 1.51 from command line, using hponcfg v4.2.0 under CentOS 6.5.

 

I've successfully configured REMOTE_SYSLOG_SERVER_ADDRESS and REMOTE_SYSLOG_PORT, but I still can't switch REMOTE_SYSLOG_ENABLE to Y :

 

# cat << EOF |hponcfg -i
> <RIBCL VERSION="2.0">
>   <LOGIN USER_LOGIN="xxx" PASSWORD="xxx">
>     <RIB_INFO MODE="write" >
>       <MOD_GLOBAL_SETTINGS>
>         <REMOTE_SYSLOG_ENABLE VALUE="Y" />
>       </MOD_GLOBAL_SETTINGS>
>     </RIB_INFO>
>   </LOGIN>
> </RIBCL>
> EOF
HP Lights-Out Online Configuration utility
Version 4.2.0 Date 6/10/2013 (c) Hewlett-Packard Company, 2013
Firmware Revision = 1.51 Device type = iLO 4 Driver name = hpilo
</-- ERROR :      STATUS= 0x00BE
     MESSAGE= Tags for Remote Syslog cannot be empty. -->
Script failed 
# 

 

And here's the full GET_GLOBAL_SETTINGS output :

 

<GET_GLOBAL_SETTINGS>
<!-- A session timeout value of zero means that the timeout is set to infinite. -->
    <SESSION_TIMEOUT VALUE="0"/>
    <ILO_FUNCT_ENABLED VALUE="Y"/>
    <F8_PROMPT_ENABLED VALUE="Y"/>
    <F8_LOGIN_REQUIRED VALUE="N"/>
    <HTTPS_PORT VALUE="443"/>
    <HTTP_PORT VALUE="80"/>
    <REMOTE_CONSOLE_PORT VALUE="17990"/>
    <VIRTUAL_MEDIA_PORT VALUE="17988"/>
    <SNMP_ACCESS_ENABLED VALUE="Y"/>
    <SNMP_PORT VALUE="161"/>
    <SNMP_TRAP_PORT VALUE="162"/>
    <SSH_PORT VALUE="22"/>
    <SSH_STATUS VALUE="Y"/>
    <SERIAL_CLI_STATUS VALUE="Enabled-Authentication Required"/>
    <SERIAL_CLI_SPEED VALUE="115200"/>
    <VSP_LOG_ENABLE VALUE="Y"/>
    <MIN_PASSWORD VALUE="8"/>
    <AUTHENTICATION_FAILURE_LOGGING VALUE="Enabled-every 3rd failure"/>
    <LOCK_CONFIGURATION VALUE="N"/>
    <RBSU_POST_IP VALUE="Y"/>
    <ENFORCE_AES VALUE="N"/>
    <IPMI_DCMI_OVER_LAN_ENABLED VALUE="Y"/>
    <REMOTE_SYSLOG_ENABLE VALUE="N"/>
    <REMOTE_SYSLOG_PORT VALUE="514"/>
    <REMOTE_SYSLOG_SERVER_ADDRESS VALUE="log.mydomain.tld"/>
    <ALERTMAIL_ENABLE VALUE="N"/>
    <ALERTMAIL_EMAIL_ADDRESS VALUE=""/>
    <ALERTMAIL_SENDER_DOMAIN VALUE=""/>
    <ALERTMAIL_SMTP_PORT VALUE="25"/>
    <ALERTMAIL_SMTP_SERVER VALUE=""/>
    <PROPAGATE_TIME_TO_HOST VALUE="N"/>
</GET_GLOBAL_SETTINGS>

 

Does anyone know what I'm missing ?

 

Cheers,

4 REPLIES
Jimmy Vance
HPE Pro

Re: iLO4 1.51 scripting, can't enable syslog

Try "Yes" instead of "Y"




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
yom_
Occasional Collector

Re: iLO4 1.51 scripting, can't enable syslog

Same result with "Yes" : 

</-- ERROR :      STATUS= 0x00BE
     MESSAGE= Tags for Remote Syslog cannot be empty. -->

 

Jimmy Vance
HPE Pro
Solution

Re: iLO4 1.51 scripting, can't enable syslog

I almost suggested this, but I asked the program manager for the XML scritpting and here is the response.

 

 

All the 3 tags in of the Remote syslog are required with data for enabling  the syslog. But when it comes to modify the value of Port / Address / Disabling Remote syslog then just executing the script with individual tags will work. 

 

Ex: for enabling the Remote syslog.

<RIBCL VERSION="2.0">

  <LOGIN USER_LOGIN="adminname" PASSWORD="password">

<RIB_INFO MODE="write">

         <MOD_GLOBAL_SETTINGS>

                   <REMOTE_SYSLOG_ENABLE VALUE="Y"/>

                    <REMOTE_SYSLOG_PORT VALUE="514"/>

                    <REMOTE_SYSLOG_SERVER_ADDRESS VALUE="abcd.com"/>

</MOD_GLOBAL_SETTINGS>

  </RIB_INFO>

  </LOGIN>

</RIBCL>

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
yom_
Occasional Collector

Re: iLO4 1.51 scripting, can't enable syslog

Thanks for your help.