ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

iLo4 and 'alertmail'

 
waaronb
Respected Contributor

Re: iLo4 and 'alertmail'

It sounds like the ILO isn't waiting for the server message, whatever it might be, before sending stuff.  Normally that would be a sign of some spambot, but in this case it seems like the SMTP sender on the ILO just isn't very patient.

 

It's a somewhat common technique that email servers might use to flag potential spam: introduce some variable delay between when the connection is made and when whatever text is sent to the remote system, indicating it's ready.  Systems that try and send stuff before then are *probably* (but not always) some spambot infected system.  A well behaved client will wait.

 

If your email server isn't public you could try disabling that feature if possible (the "check_earlytalker" plugin it mentions).  Although I'd be a little surprised if ILO wasn't actually waiting... You could try and sniff the traffic and see if that's what's actually happening.  Or at least disable that check, see if it works, and then bug HP for a fix, because really,  it's not cool to start jabbering away before the SMTP server greets you. :)

BAC_EBP
Occasional Visitor

Re: iLo4 and 'alertmail'

Make sure you have entered an Domain Name under Network -> iLO Dedicated Network Port -> General

 

Otherwhise your <Mail From> - Adress for AlertMail will look like <Hostname>.@<SenderDomain>
Note the point between <Hostname> and @, this will cause Exchange Servers (Exchane 2013) to discard Alert Messages from this sender.

 

If you enter an Domain Name  it just works fine.
Your <Mail From> - Adress will look like <Hostname>.<DomainName>@<SenderDomain>...

 

Also make sure to use the IP-Adress instead of DNS-Name of the Mail-Server if you have not defined any internal DNS-Servers in Network -> iLO Dedicated Network Port - IPv4 Settings .

YujiEda
Occasional Visitor

Re: iLo4 and 'alertmail'

Hi all,

 

I was also the same situation.

It has been solved by the use of SSH and command.

 

example

 

cd /map1/oemhp_alartmail1

oemhp_alartmail_email=test@test.co.jp

 

 

YujiEda
Occasional Visitor

Re: iLo4 and 'alertmail'

sorry,

 

There was a mistake2.

 

Login to iLO.

 

cd /map1/oemhp_alertmail1

set oemhp_alertmail_email=test@test.co.jp

mcse4hugh
Occasional Visitor

Re: iLo4 and 'alertmail'

Your doc on setting this up would be great!

 

Paul-W
Occasional Visitor

Re: iLo4 and 'alertmail'

Greetings mate. a copy of the doc would be very much appreciated.

 

KP23
Occasional Visitor

Re: iLo4 and 'alertmail'

That is exactly the fix  [assuming all others are setup correctly ] that worked for me.

Thanks !

Runawayace
Occasional Visitor

Re: iLo4 and 'alertmail'

Can you please send me the doc that you have with the fix for this that worked for you?

Jimmy Vance
HPE Pro

Re: iLo4 and 'alertmail'

Unfortunately it doesn't appear this user has ever logged back into the forums since making this post in 2014

No support by private messages. Please ask the forum! Accept or KudoI work for HPE
RyanTausch
Occasional Visitor

Re: iLo4 and 'alertmail'

Confirmed the suggestion above "adding domain to network/general" works!

For whatever reason if the domain name field is blank under iLO Dedicated Network Port/General the Alertmail Function will not work. Also note, if your ipv6 or ipv4 is set to DHCP, the domain field is greyed out. Be sure you uncheck the ipv4 or ipv6 option "Use DHCPv6 Supplied Domain Name"

ilo4 DL380 G9, ilo fw is 2.50