ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ilo5 snmp v3 query

 
SOLVED
Go to solution
BradV
Trusted Contributor

ilo5 snmp v3 query

I need to set up snmp v3 users on a large number of servers in iLO.  So, I want to do it using hponcfg (can send to a large chunk of servers at once through salt).  I did this on one server as a test.  The user was added.  However, when I attempt to send a query, I just get a timeout.  I set with: 

USER=username
AUTHPASS='authpass'
PRIVPASS='privpass'
PASSWORD='ilopass'
INDEX=1
cat > ilo_snmp.xml << EOF
<RIBCL VERSION="2.0">
  <LOGIN USER_LOGIN="administrator" PASSWORD="${PASSWORD}">
  <RIB_INFO mode="write">
    <MOD_SNMP_IM_SETTINGS>
      <SNMP_USER_PROFILE INDEX="${INDEX}">
        <SECURITY_NAME VALUE="${USER}" />
        <AUTHN_PROTOCOL VALUE="1"/>
        <AUTHN_PASSPHRASE VALUE="${AUTHPASS}"/>
        <PRIVACY_PROTOCOL VALUE="1"/>
        <PRIVACY_PASSWORD VALUE="${PRIVPASS}"/>
      </SNMP_USER_PROFILE>
    </MOD_SNMP_IM_SETTINGS>
  </RIB_INFO>
</LOGIN>
</RIBCL>
EOF
hponcfg -f ilo_snmp.xml

Is there another setting I need to change?  I've been reading the iLO5 user guide, but have not found the answer yet.  Currently running iLO vs 1.37 and using hponcfg vs 5.4.

1 REPLY 1
Highlighted
BradV
Trusted Contributor
Solution

Re: ilo5 snmp v3 query

Figured out my problem.  The OS network is outside the firewall.  The iLO network is inside the firewall.  Once I attempted to query from a server inside the firewall, it worked!  Duh!  :)