ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

"no fixed disks detected" error on ML370

Safdar Iqbal
Occasional Contributor

"no fixed disks detected" error on ML370

I am getting "no fixed disks detected" error on my ML370. Tried several utilities to get to NTFS volume with no luck. I think it might be the array controller (431). If I replace it, what are the steps to reconfigure/update without losing any data on my drives. I do not have good backup and saving data is imperative. Your help is highly appreciated.

Kind regards,
Safdar
3 REPLIES
JohnWRuffo
Honored Contributor

Re: "no fixed disks detected" error on ML370

Safdar:

If you have a SmartStart 5.50 CD, boot off the CD and run the System Configuration Utility. Follow the promps and save the configuration. Make sure you select the Smart Array 431 Controller as the first boot device.

If you do not have a SmartStart CD, then download the SCU from here:
http://h18023.www1.hp.com/support/files/server/us/download/13227.html
You need 4 diskettes for this SoftPaq.
As stated above, run through the SCU prompts and select the 431 controller as the first boot device.

This should fix it. Let us know if you need more help? -john
Enjoy!
__________________________________________
Was the post useful? Click on the white KUDOS! Star.

Do you need help with your HP product?
Try this: http://www.hp.com/support/hpgt
Oleg Mochkin
Trusted Contributor

Re: "no fixed disks detected" error on ML370

Does this disks was in RAID array or they was connected to SCSI controller ? Message "no fixed disks" appear when SmartArray 431 start up? Or when ondoard SCSI controller ?
Safdar Iqbal
Occasional Contributor

Re: "no fixed disks detected" error on ML370

Thanks John, I ran the Conifguration Utility and all appeared to be okay, but am still getting "no disks present error". I think Array Controller is okat. Also I neglected to mentioned that the problem originaly started with one of the 5 18GB hard drives failure, which was replaced. And then I started to see "missing or corrupt ntoskrnl.exe at the boot screen (NT 4). I thought I could use some NTFS utility to copy or restore ntoskrnl.exe but without getting the C volume, it is impossible. Now I am leaning towards there might be a problem with disks. I tried NTFSDOS to mount the NTFS volume but it failed with same error "no fixed disks detected"; same when I tried FDISK.

I might to rebuild the whole thing but I would like to try all possible ways to revive it first. Any suggestions?

Kind regards,
Safdar