ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

raid / disk health check utility

FlorianSchmidt
Occasional Contributor

raid / disk health check utility

hi everyone,

I have 2 HP DL320G5p with RHEL5 installed on it and one of it isn't able to boot. I want to check the state of the raid (it is an embedded sata-raid-device) and the underlying disks.

are there any bootable tools to do this? redhat ones, or from other vendors?

or whats the beste way to get information about the devices?

thanks
florian
3 REPLIES
Blazhev_1
Honored Contributor

Re: raid / disk health check utility

Hi Florian,

what do you mean under not nooting? hangs/black screen/stops when loading RHEL?

first you can connect the HDDs of the not booting server to the embedded controller of the oher server and check if it boots.

So you will know if the problem is in the HDDs.

Monitoring tool for RHEL 5 is :

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?swItem=MTX-be48b1c0eb554039b869cd374e〈=en&cc=us&mode=3&

Diagnostic for Hardware errors of the HDDs or the controller is either to boot Smartstart CD and run offline Hardware Diags (Maintain server -> Diagnose server and go to the Test tab):

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=3579703&prodNameId=3579737&swEnvOID=4006&swLang=8&mode=2&taskId=135&swItem=MTX-ca075df7a8224f0291bfd77629

If no errors are found, please note what error are you seeing...

Gruesse












FlorianSchmidt
Occasional Contributor

Re: raid / disk health check utility

Hi Blazhev:

I was able to solve the problem in the meantime. It wasn't a hardware issue, it was a broken MBR and a broken initrd-image -.-

But I also tried your advice with the SmartStartCD. Problem is: It does not support the controller in the DL320G5p. It is named HP Embedded SATA-Raid Controller, appears in SmartStart as Intel device and at POST time as Adaptec Raid Controller. With the Array Diagnostics Utility in SmartStart it prints no report...only one blank window. With the Insight Diagnostigcs Utility I nowhere saw anything like SATA or RAID. And the Array Configuration Utility prints "there are no supported controllers".
Great tools :D

Well I got it working and hope that now everything will be fine :)

Thanks for your help
Florian
Blazhev_1
Honored Contributor

Re: raid / disk health check utility

Hi,

well I know that ADU and ACU will not detect the controller, that's why if you check my post, you will see that it is not mentioned that you must click the "diagnose array" or "conffigure array" button.
Glad to hear it worked.