ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

server freezing on boot.

 
chiphayn
Occasional Contributor

server freezing on boot.

server is an HP G3 Proliant DL140

I have a WD 2tb external drive that  is being used as a backup on the server.  I am having a problem with the Server freezing up on boot unless the 2tb hard drive is unplugged from the port.  Removable devices is setup after hard disk in the boot order so i am confused as to why the server freezes on boot with the external drive plugged in to the USB port.  And this is a huge problem because i can't reboot the server remotely if i need too.  Any suggestions?

6 REPLIES
nhbilly
Frequent Advisor

Re: server freezing on boot.

My server used to do that I think I disable every bootable device except for the one I want to boot from to eliminate the hang. What a pain.

jmquesadarivel
Frequent Advisor

Re: server freezing on boot.

your server is trying to boot from the USB drive, thats why it "freezes", go to the BIOS and change the boot order, make sure your server controller (with OS drives) is before the USB/DVD

PDP-Fan
Valued Contributor

Re: server freezing on boot.

I had a similar problem on a PC. It refused to start as long as the USB drive was connected. Then we connected it to another USB port on the rear side (it was on the front previously) and then it worked.

Seems that different USB connectors have different priorities...

 

Try this and if it doesn't help try to change boot order settings.

***********************************************
"If it seems illogical... you just don't have enough information"
chiphayn
Occasional Contributor

Re: server freezing on boot.

USB ports do have different priorities.  I did change the boot order even before i posted this problem but it did not change anything.  boot order i am using now is CDROM first, the HD.  I moved USB to last and it is still freezing on boot with the drive connected.  I have narrowed it down to the drive because when the drive is not plugged into the port, it boots with no problems.  But, front or rear, no matter which port, as long as the drive is plugged in, the server freezes at boot.  The drive test out ok and is in working order.  Also, there is no USB Legacy support located in the bios anywhere, so that solution is out.  Any Ideas?

PDP-Fan
Valued Contributor

Re: server freezing on boot.

I have a strange idea.... How about a hardware device that delays the startup of the USB drive until the server has booted? I don't know if that is available anywhere but I could make one :)

It is basically a delayed relais that activates after a couple of seconds (or minutes) after the USB is powered up.

***********************************************
"If it seems illogical... you just don't have enough information"
chiphayn
Occasional Contributor

Re: server freezing on boot.

If there is such a device, it would be a feasable solution.  From what i gather, i am not the only one with this problem.  I may actually try disabling everything from the boot order except what i would like to boot.  If there was ever a problem with this later, there is always the SW2 switch to reset the bios settings.  Worth a try i would think.