ProLiant Servers (ML,DL,SL)

smad fails to communicate with ilo5

 
SOLVED
Go to solution
Andreas5
Occasional Visitor

smad fails to communicate with ilo5

Hi!

I have a ProLiant DL385 Gen10 server running CentOS 8.2. I want to monitor my system with nagios and installed amsd.

But it doesn't seem to work. After a few seconds the smad service is started it begins to report that it can not communicate with iLO:

Oct 2 10:13:39 sicura systemd[1]: Starting System Management Assistant daemon...
Oct 2 10:13:39 sicura systemd[1]: Started System Management Assistant daemon.
Oct 2 10:14:15 sicura smad[25502]: AMS Linux AgentX sub-agent connecting to AgentX master
Oct 2 10:14:15 sicura smad[25502]: No response from iLO for Hello
Oct 2 10:14:15 sicura smad[25503]: AMS Linux AgentX sub-agent connecting to AgentX master
Oct 2 10:14:15 sicura smad[25503]: No response from iLO for Hello

If I let it run the logs get filled with many "No response from iLO for Hello" messages per second.

In iLO5 the Agentless Management Service remains in state "not available"

I first tried with amsd-2.1.0 from SPP and then upgraded to amsd-2.1.1 downloaded from the HPE support center, neither worked. I did not do any special configuration, I just installed the amsd package with yum.

Some infos:

amsd package version: amsd-2.1.1-1412.2.rhel8.x86_64

OS version: CentOS Linux release 8.2.2004 (Core)

Kernel version: 4.18.0-193.19.1.el8_2.x86_64 #1 SMP Mon Sep 14 14:37:00 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

iLO module version from /sys/module/hpilo/version: 1.5.0

iLO firmware ersion: 2.30 Aug 24 2020

System ROM version: A40 v2.42 (07/17/2020)

 

What might be wrong?

What can I do to make it work as expected?

Any idea anyone?

 

Thanks!

3 REPLIES 3
Harsh_b
HPE Pro

Re: smad fails to communicate with ilo5

Hello Andreas, 

The only way to avoid the messages when they start appearing is to reset ILO or stop/disable smad and amsd systemd services.

 

Regards

 

I am an HPE employee
Accept or Kudo
Harsh_b
HPE Pro
Solution

Re: smad fails to communicate with ilo5

Hello Andreas,

Please do let us know is below suggestons helped to fix :-

The only way to avoid the messages when they start appearing is to reset ILO or stop/disable smad and amsd systemd services.

Regards

I am an HPE employee
Accept or Kudo
Andreas5
Occasional Visitor

Re: smad fails to communicate with ilo5

Hi!

Sorry for the late reply, but I was very busy in the past couple of days.

I now followed your advice, resetted iLO (which is something I normally do not do... and indeed amsd/smad now work as expected! The error message is gone, iLO shows the state of the Agentless Management Service" as "OK"  and I can use SNMP tools to query all the relevant information I need to monitor this server.

Thank you very much for your support!

- andreas