ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

smart array 410 raid 1 rebuild very slow

oleg.alenin
Occasional Visitor

smart array 410 raid 1 rebuild very slow

Server HP Proliant ML150 G6 with Smart Array 410 controller and 2 HDDs.

After removing and inserting one of HDDs rebuild started automaticaly, but this process is very slow (passed about 10% in 16 hours). Server isn't busy. I tried "high rebuild priority" in ACU with no effect. It's normal or a bad configuration/hardware bug? Is it possible to get it rebuild faster?
10 REPLIES
juan quesada
Respected Contributor

Re: smart array 410 raid 1 rebuild very slow

hello,

very slow indeed, something must be wrong.
try flashing Firmware to the controller.
do you have controller cache memory?
is the server i/o very busy?

regards,
oleg.alenin
Occasional Visitor

Re: smart array 410 raid 1 rebuild very slow

Thank you for answer!

last firmware (v 3.30) installed. As i found there are no cache memory ("Cache Size in MB - 0Mb" in ACU diagnostic report).
Currently there are no applications running on the server, only OS (Win 2003)
juan quesada
Respected Contributor

Re: smart array 410 raid 1 rebuild very slow

can you attach ADU report?
oleg.alenin
Occasional Visitor

Re: smart array 410 raid 1 rebuild very slow

After re-inserting HDDs and reboot nothing changed. rebuild is very slow.
Report is attached
One more question: is there CLI version of Smart Array Configuration utility for windows?
Thank you.
Johan Guldmyr
Honored Contributor

Re: smart array 410 raid 1 rebuild very slow

Yeah, should be available.
ACU-CLI i believe it's called but it comes with ACU doesn't it?
juan quesada
Respected Contributor

Re: smart array 410 raid 1 rebuild very slow

correct me if im wrong.


3 x (SATA 1TB 7200 RPM) drives in a RAID 5 with no cache memory on the controller and it is split into 2 logical drives?

keep in mind that HP states that it will take 15min per GB in a rebuild process in the worst case scenario.

by looking at your configuration I can tell, this is close to a worst scenario.

recomendation is to add a cache memory to the controller, it will improve a lot the performance
oleg.alenin
Occasional Visitor

Re: smart array 410 raid 1 rebuild very slow

There are no RAID5 arrays :)

1) Two HDDs in RAID1 (mirror) - first logical drive
2) One HDD as JBOD (I couldn't find JBOD in ACU, so I created RAID0 with 1 disk) - second logical drive

The problem (slow rebuild) is with first logical drive
Gerardo Arceri
Trusted Contributor

Re: smart array 410 raid 1 rebuild very slow

What about using hpacucli to change the rebuild priority:
hpacucli ctrl slot=X modify rebuildpriority=high

You can check the current setting with
hpacucli ctrl slot=X modify rebuildpriority=?

Just my $ 0.02
Charan Jit Singh
Occasional Visitor

Re: smart array 410 raid 1 rebuild very slow

Hi

I was going through this forum I found this relevant to me, I have an another query that If one of the HDD is in rebuilding process in Raid how do I check this process via hpacucli command since I am using RHEL 5.3 on my hp server.

Thanks & Regards
Charanjit Singh
Johan Guldmyr
Honored Contributor

Re: smart array 410 raid 1 rebuild very slow

Hey!

Maybe a new thread would have been nice here?

Have you looked in the manual for ACU-CLI?

GOogled a little and it should be possible to find this in hp.com somewhere, but it appears to be here:

http://www.scribd.com/doc/4086999/HP-Array-Configuration-Utility-User-Guide

What version of ACU-CLI do you have?