ProLiant Servers (ML,DL,SL)

snmpd not working right, RedHat, HP PSP, DL360G7


snmpd not working right, RedHat, HP PSP, DL360G7

I'm having an odd problem with SNMP and the 9.10 PSP.


  • Three machines with identical fresh installs of RedHat EL 6.2
  • Install PSP 9.10, everyting installs fine but the SATA driver. which isn't connected to anything.


  • Configured /etc/snmp/snmpd.conf on machine #1
  • Restarted /etc/init.d/snmpd and everything just worked(tm)


  • copy /etc/snmp/snmpd.conf to machine #2. 
  • /etc/init.d/snmpd starts snmpd but it doesn't listen to port UDP 25375, which is how the hp-snmp agents communicate with net-snmp, snmpd does not respond to queries.
  • running snmpd by hand "/usr/sbin/snmpd -LS0-6d -Lf /dev/null -p /var/run/" on machien #2 works fine, it opens udp port 25375, responds to quieries.
  • I deduced it may be a environment problem, and added "-c /etc/snmp/snmpd.conf" to /etc/sysconfig/snmpd.
  • Now snmpd listens to port 25375 and replies to snmpwalk qurierys on startup.


  • I copyed /etc/snmp/snmpd.conf to machine #3
  • changed /etc/sysconfig/snmpd to include config file.
  • /etc/init.d/snmpd does not listen to udp port 25375. even with the command ine change
  • But still, if I run snmpd from the command line it opens udp port 25375 and all the HP special features work.


Is there some special weirdness that the PSP does to environment variables?


I'm about to go batty. Any advice wold be greatly appreciated