ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

vm's not initiallizing in Hyper-V on DL120 G7

dancody
Occasional Visitor

vm's not initiallizing in Hyper-V on DL120 G7

My boss bought this to replace our main hypervisor which failed.

 

I can't get any vm's  I create to initialize, I've checked the bios settings against those recommended here:

 

http://blogs.technet.com/b/iftekhar/archive/2010/08/09/enable-hardware-settings-in-bios-to-run-hyper-v.aspx

 

Virtualization - enabled

Execute Disable (XD) - enabled (No execute memory protection in BIOS) - enabled

 

VT-d - diabled (Doesn't work with it enabled either)

Trusted execution - can't find this, spoke to support and the said to disable TPM under Server Security in BIOS but it wasn't there - probably beacuse the TPM module is optional.

 

I've powered down and removed power cable between changing virtualisation options, reinstalled using Smart Start CD and updated  everything using the Smart Update Manager.

 

Does anyone have Hyper-V working on a DL-120 G7?

 

Any suggestion?

3 REPLIES
Jeffrey D Chard
Frequent Advisor

Re: vm's not initiallizing in Hyper-V on DL120 G7

I had a similar problem with ml110g7 that came with server 2008'r2 installed

 

Xeon e1230 processor.

 

These processors have  avx.   

 

Avx and hyper v do not worktogether.  There is a patch (which disables avx)  or you need to  install service pack 1. For more info see 

 

http://support.microsoft.com/kb/2517374

 

jeffrey

dancody
Occasional Visitor

Re: vm's not initiallizing in Hyper-V on DL120 G7

This worked, thanks.

 

It's a bit of an obscure one, how did you find this solution?

Jeffrey D Chard
Frequent Advisor

Re: vm's not initiallizing in Hyper-V on DL120 G7

Google and luck, mostly luck