ProLiant Servers - Netservers
cancel
Showing results for 
Search instead for 
Did you mean: 

Re: BL480c G1 VMWare Network Issue

 
Occasional Contributor

BL480c G1 VMWare Network Issue

When ever I try to set autonegotiate on vmnic3 we get an back "function not implemented" the same error results if I try and set it through the GUI in VIClient.

The thing is the other nic 'vmnic0' that is using the same tg3 driver is set to autonegotiate no problem for some reason vmnic3 will not set back to autoneg.

I'm wondering if it is a faulty NIC as VMWare have been unable to get it to change settings back to Autoneg also. The original issue that showed up was Vmotion failing at 10% on this server and further investigation turned up that vmkping to the other esx servers fails from this server, vmnic3 is use for the kernel on esx02 however the other esx servers could vmkping esx02.

We are using GbE2c Switch's (not the passthrough modules)

ethtool -s vmnic3 autoneg on
Cannot set new settings: Function not implemented
not setting autoneg

or

esxcfg-nics -a vmnic3
Error: Function not implemented: Function not implemented
Aborted

The same error is reported in the VIClient GUI also.

**********
this is the bad nic vmnic3
**********
ethtool vmnic3
Settings for vmnic3:
Supported ports:
Supported link modes: 1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: Not reported
Advertised auto-negotiation: No
Speed: 1000Mb/s
Duplex: Full
Port: FIBRE
PHYAD: 1
Transceiver: internal
Auto-negotiation: off
Supports Wake-on: g
Wake-on: g
Current message level: 0x000000ff (255)
Link detected: yes

*********
this is the good nic vmnic0
*********
ethtool vmnic0
Settings for vmnic0:
Supported ports:
Supported link modes: 1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 1000baseT/Half 1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: FIBRE
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: g
Current message level: 0x000000ff (255)
Link detected: yes


esxcfg-nics -l
Name PCI Driver Link Speed Duplex MTU Description
vmnic0 0a:04.00 tg3 Up 1000Mbps Full 1500 Broadcom Corporation HP NC326i Integrated Dual Port PCI Express Gigabit Server Adapter
vmnic1 03:00.00 bnx2 Up 1000Mbps Full 1500 Broadcom Corporation Broadcom NetXtreme II BCM5708 1000Base-SX
vmnic2 05:00.00 bnx2 Up 1000Mbps Full 1500 Broadcom Corporation Broadcom NetXtreme II BCM5708 1000Base-SX
vmnic3 0a:04.01 tg3 Up 1000Mbps Full 1500 Broadcom Corporation HP NC326i Integrated Dual Port PCI Express Gigabit Server Adapter


# ethtool -i vmnic3
driver: tg3
version: 3.81c
firmware-version: 5715s-v3.28
bus-info: 0a:04.1
4 REPLIES 4
Advisor

Re: BL480c G1 VMWare Network Issue

Try to consider using NC360 NIC card.
New Member

Re: BL480c G1 VMWare Network Issue

Spencer, I am having the EXACT same issue you are. Did you ever figure out what the issue was? Thank you
Occasional Contributor

Re: BL480c G1 VMWare Network Issue

Finally I got to someone in VMWare that new how to get it out of the fixed speed and duplex settings, I have performed the steps below and confirm they work as I now have the nic back to Auto/Auto....

In order to manually switch the NIC back to Auto you need to edit the /etc/vmware/esx.conf file and remove the lines that force the speed and duplex. For example, looking at the vm-support dump I have from host "esx02" we can see the following in the config file:

/net/pnic/child/duplex = "full"
/net/pnic/child/mac = "00:1a:4b:ff:11:fa"
/net/pnic/child/name = "vmnic3"
/net/pnic/child/speed = "1000"

VMNIC3 is currently configured to be forced to 1000/Full. If you delete the speed and duplex lines then reboot the ESX host the NIC should come back up as Auto. I have tested this on a BL480c in my lab. Please make a backup of the esx.conf file prior to editing the file.
Occasional Contributor

Re: BL480c G1 VMWare Network Issue

BTW Getting the NIC back to Auto/Auto did not solve Vmotion failing at 10%, When this occurs VMKping fails from this host...