ProLiant Servers - Netservers

Boot problems, iLO 4 self-test error, Smart Array Boot drive missing

 
empeiro
Occasional Advisor

Boot problems, iLO 4 self-test error, Smart Array Boot drive missing

Hello, my ProLiant MicroServer Gen8 won't boot anymore after I switched it of for a couple of days.
Now it shows during boot:


>>iLO 4 has detected a self-test error. For details, consult the iLO 4 Server and iLO4 Diagnostics page. 1502: iLO 4 is disabled. Use the Security Override Switch and iLO 4 F9 ROM-Based Setup Utility to enable iLO functionality.<<
(iLO was deactivated already before)
>>HP Dynamic Smart Array B120i RAID Controller (v3.54.0, 0MB) 0 Logical Volume 1785-Drive Array Not Configured Run Array Configuration Utility

Press <F5> to configure .... 

Boot Logical Drive is configured but is Missing or Offline<<
(Array was configured, I tried to reset it but not working)


Entering Intelligent Provisioning (F10) is not possible, it shows a prompt for a view seconds and then try to boot from NIC.


Is there maybe a plug detached?


Tank you for your help!

10 REPLIES 10
Ihaqueit
Valued Contributor

Re: Boot problems, iLO 4 self-test error, Smart Array Boot drive missing

Power on the server within a minimal configuration

I Haq
empeiro
Occasional Advisor

Re: Boot problems, iLO 4 self-test error, Smart Array Boot drive missing

Hello Ihaqueit,
thank you for your Answer! I disconnected 1 Dimm and Drives (Also SAS plug - so just 1 Dimm, Keyboard, VGA and Network connected) but it still shows ilo error and Intelligent Provisioning just shows a promt for a short time.
Anything elese I could check?

 
 
 
 
Ihaqueit
Valued Contributor

Re: Boot problems, iLO 4 self-test error, Smart Array Boot drive missing

What is the firmware version?

Try to reformat the NAND.

If still issue replaced the systemboard.

I Haq
empeiro
Occasional Advisor

Re: Boot problems, iLO 4 self-test error, Smart Array Boot drive missing

Hello, how can I reformat the NAND without OS?

here are the fw-versions:

Smart Array v3.54.0 (1.07)

Bios J06 (04/04/19)

HP AHCI SATA Controller v0.84

Broadcom UNDI PXE-2.1 v17.2.1

 

ksram
HPE Pro

Re: Boot problems, iLO 4 self-test error, Smart Array Boot drive missing

Hi empeiro,

 

Please refer the link : https://internal.support.hpe.com/hpesc/public/docDisplay?docLocale=en_US&docId=a00048622en_us to get information related to NAND format.

You may see multiple options here.

 

Regarding the Intelligent Provisioning, try flashing IP to the next version or the latest version and try accessing.

 

Let us know the results.

 

Thank you

RamKS


I work for HPE

Accept or Kudo

Ihaqueit
Valued Contributor

Re: Boot problems, iLO 4 self-test error, Smart Array Boot drive missing

Can you attach error screenshot.?

I Haq
empeiro
Occasional Advisor

Re: Boot problems, iLO 4 self-test error, Smart Array Boot drive missing

Hello ksram,

thank you for your answer, somehow I'm not able to perform the reset. It seems the script is not working.

I installed Open Suse live (15.3) on a flash drive, and downloaded hponcfg from here and installed hponcfg-5.6.0-0.x86_64.rpm.

Worked weill but shows missing signature / key:

Spoiler

linux@localhost:~/Downloads> sudo zypper install hponcfg-5.6.0-0.x86_641.rpm
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW package is going to be installed:
hponcfg

1 new package to install.
Overall download size: 59.0 KiB. Already cached: 0 B. After the operation,
additional 174.0 KiB will be used.
Continue? [y/n/v/...? shows all options] (y):
Retrieving package hponcfg-5.6.0-0.x86_64 (1/1), 59.0 KiB (174.0 KiB unpacked)
hponcfg-5.6.0-0.x86_641.rpm:
Header V3 RSA/SHA256 Signature, key ID 26c2b797: NOKEY
V3 RSA/SHA256 Signature, key ID 26c2b797: NOKEY

Looking for gpg key ID 26C2B797 in cache /var/cache/zypp/pubkeys.
Repository Plain RPM files cache does not define additional 'gpgkey=' URLs.
hponcfg-5.6.0-0.x86_64 (Plain RPM files cache): Signature verification failed [4-Signatures public key is not available]
Abort, retry, ignore? [a/r/i] (a): i

Checking for file conflicts: .............................................[done]
(1/1) Installing: hponcfg-5.6.0-0.x86_64 .................................[done]
Additional rpm output:
warning: /var/cache/zypper/RPMS/hponcfg-5.6.0-0.x86_641.rpm: Header V3 RSA/SHA256 Signature, key ID 26c2b797: NOKEY

I created the xml file as shown in your link.

Then tried to execute hponcfg-5.6.0-0.x86_64.compsig but just errors apperd:

Spoiler

sudo ./hponcfg-5.6.0-0.x86_64.compsig -l Force_Format.xml
./hponcfg-5.6.0-0.x86_64.compsig: line 1: /Begin: No such file or directory
./hponcfg-5.6.0-0.x86_64.compsig: line 2: Fingerprint: command not found
./hponcfg-5.6.0-0.x86_64.compsig: line 3: Key:: command not found
./hponcfg-5.6.0-0.x86_64.compsig: line 4: Hash:: command not found
./hponcfg-5.6.0-0.x86_64.compsig: line 5: Signature:: command not found
./hponcfg-5.6.0-0.x86_64.compsig: line 6: Fingerprint: command not found
./hponcfg-5.6.0-0.x86_64.compsig: line 7: /End: No such file or directory
./hponcfg-5.6.0-0.x86_64.compsig: line 8: $&apos;HPIMAGE\001\001ݷ\250\347\300\246V@\261J\227\274B=\334{@\377\377\377\3777wpD\020\344\a&apos;: command not found
./hponcfg-5.6.0-0.x86_64.compsig: line 9: syntax error near unexpected token `(&apos;
./hponcfg-5.6.0-0.x86_64.compsig: line 9: `5.6.0-0HPE Lights-Out Online Configuration Utility for Linux (AMD64...�� 3�qL��������&apos;
linux@localhost:/opt/hp/tools&gt; sudo zypper install hash
Loading repository data...
Reading installed packages...
&apos;hash&apos; not found in package names. Trying capabilities.
<font color="#AA0000">No provider of &apos;hash&apos; found.</font>
Resolving package dependencies...
Nothing to do.

I didn't get where to find the key so I tried a reset by using the Online ROM Flash Component.

I installed it and executed the script, worked well:

Spoiler

LASH_iLO4 v1.17 for Linux (Sep 30 2015)
(C) Copyright 2002, 2015 Hewlett-Packard Enterprise Development Company, L.P.
Firmware image: ilo4_278.bin
Current iLO 4 firmware version 2.50; Serial number ILOCZ144200G3

Component XML file: CP046465.xml
CP046465.xml reports firmware version 2.78
This operation will update the firmware on the
iLO 4 in this server with version 2.78.
Continue (y/N)?y
Current firmware is 2.50 (Sep 23 2016 00:00:00)
Firmware image is 0x1001b1c(16784156) bytes
Committing to flash part...
******** DO NOT INTERRUPT! ********
Flashing is underway... 100 percent programmed. \
Succeeded.
***** iLO 4 reboot in progress (may take more than 60 seconds.)
***** Please ignore console messages, if any.
iLO 4 reboot completed.

I rebooted and tried to enter Intelligent Provisioning by pressing F10 but still nothing happens, just showing a promt. Also entering raid configuration (F5) is not possible. During boot it displays the same iLO self test error as before.

How can I fix the hponcfg script?

 
empeiro
Occasional Advisor

Re: Boot problems, iLO 4 self-test error, Smart Array Boot drive missing

Hello Ihaqueit,

it just shows a promt when i try to enter Intelligent Provisioning (black screen and promt in the upper left corner). Entering raid config is not possible, it just continues booting. Ilo error message like in my first post

Ihaqueit
Valued Contributor

Re: Boot problems, iLO 4 self-test error, Smart Array Boot drive missing

Please update the BIOS. Once done then please check if you are still getting the issue.
If the issue is still seen then please contact HPE Technical Support for any additional information or troubleshooting this issue.

I Haq