ProLiant Servers - Netservers

Can't see HDD drivers when installing Ubuntu

 
SOLVED
Go to solution
Peter_cq
Occasional Visitor

Can't see HDD drivers when installing Ubuntu

My Gen10 microserver is with one SSD and two HDDs. When I am tring to install Ubuntu, only SSD is shown. After the Ubuntu installed on SSD, I still can't see the HDDs. I have tried `sudo fdisk -l` and `sudo lsblk`. There is no HDDs in the results. But when I enter grub command line after rebooting,  results of `ls` command shown there are three disks.

What should I do to get these HDDs back into the Ubuntu? Any suggestions?

2 REPLIES 2
Paul_J_K
HPE Pro

Re: Can't see HDD drivers when installing Ubuntu

I doutb whether the Gen10 Microserver is listed to be fully supported. This also is subject to the version of ubuntu, hard drives and controllers in use as well. 

As per quickspecs Operating Systems and Virtualization Software
Support for ProLiant Servers
Microsoft Windows Server 2012 R2
Microsoft Windows Server 2016
Red Hat Enterprise Linux (RHEL) 7.4
ClearOS

Also refer the OS support matrix

http://h17007.www1.hpe.com/us/en/enterprise/servers/supportmatrix/ubuntu.aspx#.XSMlG-gzZaQ

https://certification.ubuntu.com/server/models/?vendors=HPE&page=2

You may also try to check with the Canonical community support to see if there is anything else to be checked.

I am an HPE employee
Accept or Kudo
Peter_cq
Occasional Visitor
Solution

Re: Can't see HDD drivers when installing Ubuntu

I solved this problem, but I don't know how.

First, I got two blank disk so I can do whatever I want without worrying about the data.

Second, made raid 1 for these two disks.

Then, the disk can be seen in Ubuntu. 

But, I don't need raid. So I delete raid configration and tried another solution.

During these procedure, I turn off SMART of these two disks on raid GUI interface. Then I got this problem: https://community.hpe.com/t5/ProLiant-Servers-Netservers/Microserver-Gen10-hangs-on-boot/td-p/6987843#.XSNDs-gzZPY

So, First, I initialize BIOS.

Second, reboot and enter the live-USB system

Third, "hot-plug" in my disks.

Then, after runing `lsblk`, Surprisingly, I found the disk.

Problem solved!

I don't know which step is critical, So I wrote them down for you to decide.

If you figure it out, let me know.