ProLiant Servers - Netservers

DL380 Raid rebuild Fails

Joe Bogacki
New Member

DL380 Raid rebuild Fails

I had a drive go bad on my raid 5 (3 drives). I install the replacement and it reaches around 80- 90 percent and fails. I get teh below error.

Error: 'SysErr: Recovery of logical drive 1 on the Compaq Integrated Smart Array Controller was aborted. An unrecoverable read error occurred while rebuilding the hard disk drive with drive ID 21. The hard disk drive reporting the error is drive ID 18. '

1: Tried numerous replacement drives

Any advice?
Mark Matthews
Respected Contributor

Re: DL380 Raid rebuild Fails

Have they all been either brand new / known working drives that you've tried?

Sounds like it might be the bay in the drive cage.

Try updating the FW of the server, Array controller and the disks

Easiest way is by using a FW Maintenance CD.
Latest version is 8.20, although you dont say what generation your server is...(8.20 might be too new)

Please click the white Kudos star to the left if this post is helpful :)
Sulzer Gottfried
Occasional Visitor

Re: DL380 Raid rebuild Fails

forget it. you have read errors on disk id=18. only thing you can do: backup, cahnge disk id 18 too, create new array and restore