ProLiant Servers - Netservers

Display Emulator don't work on displayport in HPE Microserver gen10+

Go to solution

Display Emulator don't work on displayport in HPE Microserver gen10+

Hi! I worked before with the HPE Microserver Gen10, and we connect via Teamviewer. To reach FullHD resolution, need a "fake monitor" (Display Emulator) connected in the displayport output. We tried with VGA, but the resolution turns unreadable. Recently, Gen10 outed of production and appear Gen10+. When we connect the VGA, appear de same that old Gen10. But when connect the DisplayPort, don't recognize and the resolution appear like a no display connection. (We work on Debian OS)

I tried update Bios Firmware but don't work. I tried the Display Emulators on other computers and works fine. 

I have around 30 Gen10+ servers and work in low-resolution is awful. For infrastructure is impossible connect some display in the servers.

¿What can I do?


Re: Display Emulator don't work on displayport in HPE Microserver gen10+


Microserver Gen10s comes with Display Ports 1.2,follow the server quickspecs,

Are you trying to connect the display port dongle adapter cable to transfer the DisplayPort to a VGA source?

If yes, the DisplayPort design for DisplayPort 1.2 requires an “active” dongle adapter cable to transfer video output.

To isolate whether it is display port adapter or display driver issue, please install OS using the VGA port and later switch to display port.

You may also connect to a monitor having display port (i.e. display port to display port connection)

Advisory: (Revision) HPE ProLiant Gen10 and ProLiant Gen10 Plus Servers - Video Loss or Black Screen May Occur When Connecting Through Either the Video Graphics Array (VGA) Connector or DisplayPort Connections

I hope below Intel link will help you.

Let me know if the issue still persist.

If you feel this was helpful please click the KUDOS! thumb below!   


I am a HPE Employee

Accept or Kudo

Occasional Visitor

Re: Display Emulator don't work on displayport in HPE Microserver gen10+


this is china server team ,a few days ago ,I have a similar case about DP not working in HPE Microserver gen10+.

We ran some tests and the results were as follows:
1.Upgrade the ILo firmware to 2.44 is invalid
2. We observed that when the DP cable was inserted when the equipment was completely powered off(Pull out the plug), the subsequent equipment could work normally no matter what. But normal operation or a hot restart will not be resolved.

One more question.
In the MSG
There is such a description about DP, but i don't understand it. Could you please explain it in detail or have relevant pictures web link
The display port does not support passive type adapters. Passive adapters are marked with the DP++ symbol. To ensure proper videodisplay when connecting an HDMI or DVI display to the display port, use only active type adapters.

Could you please explain the above statement? We are anxious to deal with it. Please reply quickly

My personal email address is

Looking forward to your reply.