ProLiant Servers - Netservers

Gen8 B120i woes with 6TB hdd and ESXi (5.5 / 6.0)

Occasional Contributor

Gen8 B120i woes with 6TB hdd and ESXi (5.5 / 6.0)

Hi everyone,


I'm trying to setup ESXi 5.5 and 6.0 on a Gen8 Celeron with 2 HDD - a small 100Gb HDD (in ODD) and a 6Tb one (WD Green) in one of the bays.

It looks like the 6Tb / Advanced format / 4K drive is not read properly by the ESXi drivers...


I've been using it for months with a bare-metal linux installation which was able to see the data on the 6Tb drive no matter what selection I used in the BIOS: "SATA Legacy" (or IDE), "SATA AHCI" or Smart Raid controller (with RAID 0 configuration).


After perfoming a memory upgrade (adding an extra 8 Gb) I've decided to move to ESXi - and this is where my problems started. Basically unless the 6 Tb drive is used in "SATA Legacy/IDE", it is not read properly in ESXi whether 5.5 or 6.0: 


* with B120i enabled


ESXi 5.5 and 6.0 install properly (onto an USB stick), I can see the drives in the hardware information however the information from the 6 Tb drive is not properly read; basically the partition information and the data is messed up and the system simply won't boot. Note that I've tried using it as a RDM (both physical and virtual) to no avail.

Switching the exact same hardware to a bare-metal configuration boots up just fine.


* with "SATA AHCI" mode


This configuration completely messes up ESXi; the install won't work (gets stuck when gathering system requirements) or, if ESXi was already installed it starts up and soon after stops seeing the drives  (only displays "Loading...") and freezes.


The only way to read the data looks to be "SATA Legacy" which maps the drives as IDE and allows the information to be read properly in RDM mode.


Do note that I have tried a variety of combinations, in all cases using the HP official ESXi images:

ESXi 5.5 U2 from November

ESXi 5.5 U2 from January with the latest ESXi 5.5 patch

ESXi 6.0 from March

ESXi 6.0 from June with the latest ESXi 6.0 patch


One thing that I've noticed is that the "SATA AHCI" seemed to work when using the ESXi 5.5 U2 from November. However applyng the latest ESXi 5.5 patch (and thus updating the esx-base and the sata-ahci) breaks this again.


Anybody has any suggestions on how to fix this? It looks like 6 Tb / Advanced drives are simply not properly supported ...


Re: Gen8 B120i woes with 6TB hdd and ESXi (5.5 / 6.0)

Hi adibarbu,

I've had the same issue with the B120i, so I use "scsi-hpvsa-5.5.0-88OEM.550.0.0.1331820.x86_64.vib". Used on all versions from ESX 5.5 to 6.0 U3. I have one 8TB drive and it works fine. Just apply this driver after an install/update.

You may find these drivers from the HPE vib depot.

If you find a newer driver that works well, please let me know.