ProLiant Servers - Netservers

HP Microserver Gen8 Nand problem

Occasional Contributor

HP Microserver Gen8 Nand problem

So I got this week a second hand HP Microserver Gen8 what had been used for home nas for a couple of years. Nothing on server was upgraded so I upgraded everything what I could to the latest version.

iLO Diagnostics states:

Controller firmware revision 2.10.00 NAND read failure: Media is in a WRITE-PROTECTED state 

and an exclamation mark with the message:

ProLiant MicroServer Gen8 System Programmable Logic Device version 0x06 


Now, i tried everything what i found about this problem, my gut tells me that it`s a faulty motherboard. Howewer one interesting thing found out was, if i downgrade iLO to version 2.54 and perform a NAND format with the server off, the whole Diagnostics page goes green, state of NAND becomes OK. Untill i boot up the server. Than it changes again back to "Failed restart/Initialising media" state.

Is there anything i can do? How can i configure a new Array without the HP Smart Array Assistant or Inteligent Provisioning? Is it safe to use this way the server?

Thank you in advance,

Occasional Visitor

Re: HP Microserver Gen8 Nand problem


had the same problem on a DL360p gen8, I tried all possible procedures. And I also noticed the behaviour with 2.54 firmware. Unfortunately, after the format, the system should be able to write again to the NAND and as soon it realize it is not possibile you get the error again. At the end I had to change the motherboard.

You can try one last procedure to force flash the iLO firmware:

- download latest FW:
- download
- open the chassis and set the ilo security switch to on
- copy CP042663.scexe to hp\swpackages of SPP
- boot SPP and go interactive
- hold CTRL+ALT then type "DBX" and release
- go to /mnt/cdrom/hp/swpackages
- remove hpilo module: rmmod hpilo
- flash ilo: sh CP042663.scexe -–direct (don't be scared, it needs time to get the connection to iLO back)
- don't forget to set the ilo security switch back to off at the end

As long as you don't need SD boot, Intelligent Provisioning or AHS log you can use the server normally. If you need SSA you can find it inside SPP, just boot it and it should be an option after you go interactive.



Re: HP Microserver Gen8 Nand problem


I would suggest you log a support ticket with the HPE  for system board replacement.

If you feel this was helpful please click the KUDOS! thumb below!   


I am a HPE Employee

Accept or Kudo