ProLiant Servers - Netservers
cancel
Showing results for 
Search instead for 
Did you mean: 

HP Microserver Gen8 SATA AHCI 4TB drive not recognized

AronW
Frequent Visitor

HP Microserver Gen8 SATA AHCI 4TB drive not recognized

Hi to all,

I have bought a Microserver Gen8 to make a small home server. I have bought also some Western Digital GOLD 4TB hard drives and I have tried to install one of those in the front slot 1.

Before installing the drive (that was checked for errors with wd utility full test to be sure that was ok), I have decided to set the controller to SATA AHCI mode, so later I can use software raid for controlling the storage array.

 Something strange happens.

 When I have booted the microserver for the first time with hard drive installed the hard drive was recognized (I have seen it on the boot sequence) but with a strange message "ATA security state of this disk is invalid". After restart/shutdown of the microserver the drive wasn't recognized anymore. I have tried everything, from re-insert the drive in the slot, check backplane cables, check again the drive on another pc with wd utility, nothing, no errors on it, the drive is ok but isn't recognized anymore.

If I listen the sound it emits when it is installed on the microserver, at the start I can hear the usual spin-up of the motor, then when the boot sequence arrives at "HP AHCI SATA controller....initializing" I can hear the the motor spin-down and it isn't recognized (no message). Reset the server don't restart the the hard drive motor, the only thing is a shutdown of the microserver.

 Later I have tried to set again the controller in HP Smart Array RAID MODE and with F5 I have entered the smart array manager setup. Here I can see that the drive is recognized again. Changed again the controller in SATA AHCI and it isn't recognized anymore, same as before.

The diagnostic of the microserver is ok, no errors. The microserver is new HPE 2017 version. BIOS is obviously the last J06 (11/02/2015). And for be sure before using the server I have used the SPP from usb for check that all is updated.

 Do you have some suggestions or maybe someone know something more about this problem? Like I have said before. when I have booted the microserver for the first time and the hard drive was recognized (the only time) what could be that strange message: "ATA security state of this disk is invalid" ? Someone who has his drive recognized can gently confirm me that he sees the same message during boot on his hard drive? from what I know is a security feature used most on laptop but for sure it was not enable on my WD GOLD. The drive was perfectly new, never used and sealed on his antistatic cover.

 Many thanks to all

3 REPLIES
AronW
Frequent Visitor

Re: HPE Microserver Gen8 SATA AHCI 4TB drive not recognized

Thanks Dennis,

I have read the links. Probably the more interesting is the first one about "ATA Security". I have to admit that at the moment I don't know where is the problem. I can only know that for sure it is a very strange one...

What is strange for example is that error message displayed the first time that I have inserted the disk (the only one time that it was recognized): "ATA security state of this disk is invalid". Why? How to know what parameter of ATA Security the Microserver Gen8 "thinks" its invalid? The disk is perfectly new and it has no problems....

So I have asked if someone has ever seen this error message.

At the moment I know that the hard disk is perfectly functional (I have also more than one), the microserver seems also. It is this "combination" of AHCI/bay1 and 2/GOLD that doesn't work. And why? Even if it was something that the microserver "thinks" is wrong in ATA security (supposing that this is the problem...) why it affects only the SATA3 ports (bay1 and 2). I realy hope that someone at HPE could help me. I have contacted wd also about this matter. The Microserver is an enterprise product category as is the the western digital gold, it is very strange this incompatibility...

Thanks

pepe999
Occasional Advisor

Re: HPE Microserver Gen8 SATA AHCI 4TB drive not recognized

Hi,

My 4TB WD RED was perfectly recognized by the system with the latest iLO and Int Provis but when I deleted the logical drive and used it in a usb caddy to do a backup on the 4TB it shows only 1.6 or 1.8TB depends on what system (linux, windows) I use. I know there is is the 32bit limitation to 2Tb on MBR drives but changing the partition table to GPT won't help so far. I have heard you have to boot it up over eSATA connection or through a proper UEFI system. Crystal Disk Info shows the full 4000 GBs.