ProLiant Servers - Netservers

HP microserver Gen8 - Intelligent provisioning dont boot

 
SOLVED
Go to solution
patvi42
Visitor

HP microserver Gen8 - Intelligent provisioning dont boot

Hello everybody, first one sorry for my english, I'm french guy and try to explain my problem ...

I've got a microserver gen8 since few days and want to re-install intelligent provisionning because when i press F10 on boot i go to grub version 2.02.

I try to reinstall it from iso file (HP_IPR_1.64B.iso)  with ilo mount image --> 

i try with usb key boot -->

i also try to boot from ilo and iso mount with windows10.iso (like that i want to install windows and 10 from usb key but no success too. I test my usb key on anoher computer and boot is ok....

Sometimes i also have red splash scree with illegal opcode message.

The goal is to install freenas on sdd and use 4X2TO sata disk for storage.

i must have to install Intelligent provisionning help me to create the raid0 configuration for my sdd like that i could boot on it and afeter create a raid10 for my 4 sata disk.

Thanks to help me 

Patrice

4 REPLIES 4
Jimmy Vance
Honored Contributor

Re: HP microserver Gen8 - Intelligent provisioning dont boot

This system was never intended or tested to have any type of disk drive connected to the ODD port.  THat being said, many have done this with success.  The disk controller in the system is chipset SATA and when put in a specific mode, drivers and utilities will recognise the controller as a RAID controller. The RAID function is all handled via a proprietary driver only available for a set few operating systems.  To access the ODD port with a hard drive, the controller must be in B120i RAID mode. This mode is not intended to be used without the special RAID driver.  

I can't explain what issue you are  having with the IP recovery image. Please use the USB key utility within the ISO to create your bootable key.  There is also an offline version of the  Smart Array utility that you can boot into if you can't get IP functional. 

 

No support by private messages. Please ask the forum! 
patvi42
Visitor

Re: HP microserver Gen8 - Intelligent provisioning dont boot

Thanks Jimmy for your help, 

Ok i try this afternoon with HP usb key utility 2.2.3 to : 

1 - Create an USB boot with HP_IPR_164B.iso image (this image is ok, already used with another HP microserver Gen8)

2 - Create an USB boot with SSAOFFLINE-2.65-7.0.iso (Image found oh HPE website)

3 - Create an USB boot with windows10.iso (already used with other computer)  like that i could try to install HP_SPP_2017.090..iso (already used with another HP microserver Gen8) to reinstall Intelligent Provisionning.

Have I to format USB key in a specific format (EXFat,FAT32...) ?

Tell you tomorrow if i succed in one of the 3 solutions ...

thanks a lot

patvi42
Visitor

Re: HP microserver Gen8 - Intelligent provisioning dont boot

Hello, I install an optical drive on my micorserver Gen8 and burn DVD with iso image of :

1 - HP_IPR_164B,

2 - Windows 2012 Server Standard edition

3 - HP_SPP_2017.090 image for w2012 server 

When i boot on hp_ipr_164b, the install begin but stop at 5% , 21% or 24% during my 3 test.

I succeed in install windows 2012 on 1 of the 4 disk in storage bay server and could launch HP_SPP_2017.090 with success. All the update with automatic method ar succesfully installed but i must choose legacy SATA to do that so i could create raid because my raid card does not appear. With Microserver Gen8 raid card OR SATA AHCI bios option enable i couldn't do anything .... no boot on DVD, Disk, SSD ....

To do what i want (install system on SDD and create RAID with 4 * 2TB disk, i must enable Microserver Gen8 raid card. I want to create a RAID0 with SSD to boot on and a raid10 with others for storage...

Thanks for you help ... i really don't know what to do to solve my problem. 

This end of week i will try 2 others options :

- Try to boot on Microsd card with micorserver gen8 raid card enable

- Try to install Intelligent provisionning from direct file install found on hpe website (cp031302.exe) with my windows 2012 server session when sata legacy enable

 

Patrice

 

patvi42
Visitor
Solution

[SOLVED] Re: HP microserver Gen8 - Intelligent provisioning dont boot

Hello everybody, 

For info, i solved my problem (Microserver Gen8 - intelligent provsionning don't boot - grub error) with this method :

1 - In legacy mode I install a windows server 2012 from an iso burned on DVD (with external DVD plug on ODD port) to a unique HDD in the first of the 4 bay.

2 - I install SPP with an iso file direct from windows server 2012 (HP_SPP_2017.090.iso)

3 - Install IPR direct from windows server 2012 (cp031302.exe)

4 - in B120i raid mode (BIOS) I do F5 or F10 to go to IPR to create my RAID configuration (RAID0 for SSD  and select new volume for boot primary)

Thanks.  

ps : Sorry iI don't know how to close topic ...