ProLiant Servers - Netservers
cancel
Showing results for 
Search instead for 
Did you mean: 

How to use hpssacli on Ubuntu 14.04 LTS with B120i controller (Microserver Gen8)

Goodkat
Occasional Visitor

How to use hpssacli on Ubuntu 14.04 LTS with B120i controller (Microserver Gen8)

I recently installed Ubuntu 14.04 LTS on a HP Proliant Microserver Gen8.
Before installing, I booted into the Intelligent Provisioning and set up a RAID 1 with two disks.
During installation, I had to inject HP Dynamic Smart Array B120i controller drivers for the
Ubuntu 3.13 kernel to see the logical RAID 1 volume (see launchpad.net/~hp-iss-team/+archive/ubuntu/hp-storage).

In Ubuntu, I tried to use the hpssacli (http://downloads.linux.hp.com/SDR/downloads/MCP/ubuntu/pool/non-free/)
to see the RAID 1 status. But unfortunately hpssacli says that no controllers are detected when I do

hpssacli controller all show

Then I found the hpdsa drivers for Ubuntu (http://downloads.linux.hp.com/SDR/project/ubuntu-hpdsa/ but after install,
hpssacli still does not see the B120i controller.

Is there any chance to use hpssacli with Ubuntu 14.04 and the B120i controller?

1 REPLY
Jimmy Vance
HPE Pro

Re: How to use hpssacli on Ubuntu 14.04 LTS with B120i controller (Microserver Gen8)

Are you sure the hpvsa driver is loaded? You must blacklist the ahci driver before hpvsa will load and control the drives.

 

The hpdsa driver is for the newer B140i Dynamic Smart Array and wil not work with the B120i




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!