ProLiant Servers - Netservers

Image from DL-360 G3 to G4

 
BR854332
New Member

Image from DL-360 G3 to G4

I'm trying to get a ghost image from a G3 to work on a G4, but it seems the adressing of the SCSI controllers is different. 5i and 641 on the G3, 6i and 642 on the G4. In disk management (win2k) the disks on the 5i controller is first on the G3, but on the G4 the disks on the 642 is listed first. Latest drivers is installed and should be compatible. Any suggestions?
5 REPLIES 5
Tarek Kawach
Honored Contributor

Re: Image from DL-360 G3 to G4

Hi Harald:

There is a difference in the way the controller loads under windows
- if you want that image to work on the G4 with 6i controller,

here is what you need to do.

on the DL360G3 ; install SA641 / 642 or 6400, don't have to connect anything to these controllers. once these controllers are installed in the server; boot up to windows and then update or reinstall the driver for the 641 etc.

Note: both controllers the 5i and 6i are the same; however it is the way they load is different.

once that is done then create the image and you can move the image to the G4 server and should install without giving you the stop 7b error inaccessable boot device.


Hope this helps

Best regards,

Tarek.
Hey, look a light at the end of the tunnel.
BR854332
New Member

Re: Image from DL-360 G3 to G4

On the 3G there is alreadey installed a 642 controller. The drivers for both the 5i and 642 is the latest drivers. Am i missing something here?
Tarek Kawach
Honored Contributor

Re: Image from DL-360 G3 to G4

This server only takes two drives
- so you have raid 1 or 1+0 per HP
- as long as the SA641 controller is set to first boot then you should be okay.

so what you are saying is ;

on the DL360G3 you have SA641 and 5i
and you have made an image of this using Ghost or something. and you are restoring it to the DL360G4 server.

as long as where drives are connected is the first boot order and you are not using the hardware raid for your Ghost image , then should be okay because both cards have the same driver.

So on the G4 should detect the logical drive.
and boot to the o/s.

Try to Check with Fdisk using MS-DOS or windows 98, and see if the partion info is there. or partion set active.

Fdisk will let you see if the data still there even if it is NTFS.

Note; connect only the drives you want to boot from first. I guess you have external storage encl. since you are using two controllers pci and scsi.

I would remove all drives internal or external on the G4; run Erase ;

reconnect only the o/s drives; and make sure boot controller is 6i as first.


If you reply make sure you mention how many drives and what hardware you have.

This should work fine; if you are saying both the G3 and G4 has 641 or 642 ; it is all same driver.

so What would be left is the boot controller order ; partion Active status, and or what drives you connected first.


Regards, Tarek.
Hey, look a light at the end of the tunnel.
BR854332
New Member

Re: Image from DL-360 G3 to G4

DL360G3 has 5i and 642. 2 disks internal (mirror - active partition) and a raid5 connected external to the 642 kontroller (4 disks). 5i is the boot controller

DL360G4 has 6i and 642, and the same disk config as the G3 (internal mirror, external raid5). 6i is the boot controller.

Took a ghost image of the G3 (only the mirrored disks), and when i put that on the G4 and try to boot, it stops with a bluescreen (inaccessible_boot_device) after a while.

Removed the 642 controller on the G4, and got the same bluescreen.

Firmware on the controllers updated to latest rev.

Any more suggestions?
Tarek Kawach
Honored Contributor

Re: Image from DL-360 G3 to G4

Hi Harald:

This should have worked fine with no issues. since both controllers have the same driver; however I would try this latest firmware for the 6i controller.

Offline ROM Flash for SmartStart Maintenance: ROM Update Utility - Smart Array 6i
version 2.36 A (26 Jan 05)
http://h18000.www1.hp.com/support/files/server/us/download/22339.html

That fixed issues with IRQ conflict in the G4 server bios; the chipset on the main board did not support 6i controller and IRQ between nic cards and other pci cards, cause something like IRQ conflict.

It is worth a try; however what you are doing is okay and is supported; but I would also check with Microsoft there is a few articles on how to prepair on moving the o/s from one computer to next. there is some .dll files issues; and different hardware we have to worry about.

Without doing the image; what about if you physically move the drives from G3 to G4 will that work. ??? try that if you have good backup etc.

hope this helps ; I will keep my eyes open for you if I come accross anything else.

Tarek.
Hey, look a light at the end of the tunnel.