ProLiant Servers - Netservers

Invalid address on DL380 G3 with NC7781

 
CA1251706
Occasional Advisor

Invalid address on DL380 G3 with NC7781

I have a stack of HP DL380 G3's that I am working with. Each has a 2GB bootworks partition (for server imaging). I am using a Windows 2003 base image that was built on one of these servers. All of the servers are identical.

I loaded the nc7781 firmware update (2.35), am using the Windows 2003 driver version 7.103.0.0, and for bootworks (DOS) I am using the Compaq Gigabit Ethernet DOS NDIS2 Ver 3.07 . It is not teamed, non-DHCP address (I assigned it), running at 100MBps with full Duplex connected to a Cisco 2950.

When the server boots into production after an imaging event, the NICS often report "Invalid Address" (with red question marks over the NIC icons, IPCONFIG reports 0.0.0.0 as an address) until I do a manual reboot.

What conditions will trigger "Invalid Address" error? Does the error mean invalid MAC address, or, invalid IP address? Anyone have ideas how to prevent this from occuring?
9 REPLIES 9
Tarek Kawach
Honored Contributor

Re: Invalid address on DL380 G3 with NC7781

Hi Kevin:

I don't know if you have seen this advisory.


Embedded NC7760, NC7780 and NC7781 Gigabit Server Adapters May Initialize With An Unknown Link State And An Invalid MAC Address Containing All Zeroes


customer advisory CO030310_CW02 revision 1
released May 2004

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=PSD_CO030310_CW02

Best regards,

Tarek.

Hey, look a light at the end of the tunnel.
CA1251706
Occasional Advisor

Re: Invalid address on DL380 G3 with NC7781

Thanks! I saw the advisory, but it talks about Linux (I'm using Win2003). Regardless, I tried the latest firmware update, and it didn't help.

Please keep the ideas coming!
Tarek Kawach
Honored Contributor

Re: Invalid address on DL380 G3 with NC7781

There is one more thing you can do which is make sure you have all the firmware uptodate on the server and controllers also the nic card.

can do from here:
Firmware Maintenance CD
version 7.20 (14 Feb 05)http://h18000.www1.hp.com/support/files/server/us/download/22489.html

-
or if you want just the nic card. http://h18000.www1.hp.com/support/files/server/us/revision/8201.html

-
HP NC10xx/67xx/77xx/150x/320x Gigabit Ethernet NIC Driver for Windows Server 2003
version 7.103.0.0 (14 Feb 05)http://h18000.www1.hp.com/support/files/server/us/download/22190.html
-
HP NC10xx/67xx/77xx/150x/320x Gigabit Server Adapter Online Firmware Upgrade Utility for Windows 2000/Server 2003
version 1.0.0.9 (16 Dec 04)http://h18000.www1.hp.com/support/files/server/us/download/21749.html
--
NCx7xx Firmware and PXE Update Utility
version 1.2 A (2 Jul 03)http://h18000.www1.hp.com/support/files/server/us/download/18479.html

- Tarek.
Hey, look a light at the end of the tunnel.
CA1251706
Occasional Advisor

Re: Invalid address on DL380 G3 with NC7781

Here's an update: I have tried Microsoft's KB840711; manually setting the duplex&speed; upgrading to bootram 2.35; and upgrading the Win2003 driver to the latest version and the problem still occurs.

This is a popular server. There must be other people running Win2003. Granted, I'm try to do load balancing - but the problem occurs even if I disable the NLB NIC.

Any ideas?
CA1251706
Occasional Advisor

Re: Invalid address on DL380 G3 with NC7781

Some more updates:
I tried deleting the NC7781's from the device manager and redetecting them. I tried to completly remove NLCB. I tried using a mini 8-port switch instead of a Cisco 2950. And I tried HP's update: CP004977. I tried all the links suggested in this thread. None of this improved the situation.

Any more ideas?
CA1251706
Occasional Advisor

Re: Invalid address on DL380 G3 with NC7781

Update: I updated the NDIS driver to V.7.65 and am now having difficulty connecting to the Altiris server (error 53). It appears that was a step backwards.
CA1255998
New Member

Re: Invalid address on DL380 G3 with NC7781

I have the exact same problem. Even tried to change NIC to a 7771, but the same problem occurs. Please help, this is driving me up the wall!!
CA1251706
Occasional Advisor

Re: Invalid address on DL380 G3 with NC7781

Here's an update: The NC7781 has two ports, so, I disable the second port within Win2003. Next, I enabled the port on the NC7771. I am running with one NC7781 port, and one NC771 port....

.... same problem.
CA1251706
Occasional Advisor

Re: Invalid address on DL380 G3 with NC7781

Some more information: I turned logging on (in the Deployment Server control pannel (set to level 3), in the aclient loaded on each server). When the server is coming out of a bootworks operation, it tries to reconfigure. After the reconfigure, the logs report a problem getting the server to restart.