ProLiant Servers - Netservers

ML370 G2 RAID problem. Mirror broken and wont start

New Member

ML370 G2 RAID problem. Mirror broken and wont start


I have a Compaq ML370 G2 with a 5300 Smart Array (Rev.A Ver.1.76). OS = Win2K Server (Member Server)

Current Array configuration
Logical drive 1 - 2x9.1Gb drives in a mirror set (System drive)
Logical drive 2 - 3x36.4Gb drives in RAID 5

My problem is with Logical drive 1.
Before running MDAC 2.8 to fix a BackupExec 9.1 problem I took the precaution of checking bakcups ok and also decided to remove one of the mirrored disks as a quick roll-back.

I shutdown server and removed disk1 from the mirror set. Leaving disk0.

I test booted the server with disk0 only and the disk1 was detected as missing/failed. This was ok. It booted up.

Again I shutdown and removed disk0 and reinserted disk1.

I test booted the server with disk1 only and no system disk error on boot. Thought, hmmm...strange.

Tried shutdown and swap around knowing disk0 worked ok. Shock horror...disk0 now dead. Hmmm?

Any ideas how I could get disk1 to boot. I'm stuck and is a production server.

Worst case scenario, I can restore from backup. But would prever to get the mirror on disk1 up and running instead.

Please help.

Occasional Advisor

Re: ML370 G2 RAID problem. Mirror broken and wont start

This is as far I remember (dont have a server to test with).
During boot, when you see the controller Bios, access the setup - this is where I cant remember the exact sequence - I think it is "Advanced" choose "read configuration from disk" (Configurations are stored on the disks).
That should do the trick.