ProLiant Servers - Netservers
cancel
Showing results for 
Search instead for 
Did you mean: 

Microserver B120i RAID Controllers | Array corrupts when connecting an additional HDD

firefly2000uk
Collector

Microserver B120i RAID Controllers | Array corrupts when connecting an additional HDD

Microserver GEN8 with B120i RAID controller.Server is running Windows Server 2012 (fresh installation) installed using the HP smart software (so includes all the drivers etc)

ADU Version 1.6.17

 

I'm finding this hard to understand but when I insert a 3rd HDD into my Microserver (GEN8) the RAID1 array becomes corrupted and shows as failed...

Please could anyone confirm if this is a configuration issue and what maybe the cause?

 

1) 2 x 4TB HDDs (Slots 1&2) working RAID1 array

2) Insert a HDD into Slots 3 or 4 and the RAID1 array fails

3) HP Smart Storage Administrator shows "Logical Drive 2 has failed and cannot be used. All data on this logical drive has been lost"

3) 4TB HDD Mirror then becomes unavailable in Server 2012 R2

4) Both 2 x 4TBs still show as Online in the HP Smart Storage Administrator

 

I fully tested this by creating a new array, then installing a new HDDs. This problem seems to happen as soon as another HDD is inserted.

 

I've attached screenshots of the RAID status AFTER the additional HDD has been connected.

 

 

Insert 3rd 250GB into the server

HP_Smart_Storage_Admin_Insert_NEW_HDD.png

 

Breaks RAID and shows the "failed logical drive" error message

Note: Both 2 x 4TB have not failed (they are fully working) only the logical drive shows errors (whichs means you can't view anything on the disk and doesn't show in Windows OS)

HP_Smart_Storage_Admin_Failed_Logical_Drive.png

 

Diagnostics report showing all data has been lost.

HP_Smart_Storage_Admin_Diagnostics_Report.png

3 REPLIES
firefly2000uk
Collector

Re: Microserver B120i RAID Controllers | Array corrupts when connecting an additional HDD

As another example of my errors. When I unplug and replug the 250GB HDD into BAY4 the RAID disks show as completely failed and all settings are lost. 

 

Why does this happen when the "Logical Drive" has ONLY been configured using BAY1 & 2?

Why would BAY3&4 have any connection to this Array?

 

HP_Smart_Storage_Admin_Failed_Drives.png

tatobrutto
Occasional Visitor

Re: Microserver B120i RAID Controllers | Array corrupts when connecting an additional HDD

Hi, I'm having the same problem. Did you find a solution?

Jimmy Vance
HPE Pro

Re: Microserver B120i RAID Controllers | Array corrupts when connecting an additional HDD

In the original post it appears drives are being hot-plugged. The Microserver Gen8 does not support hot-plug




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!