ProLiant Servers - Netservers

Microserver G8 + ESXi +AHCI = some problems

 
SOLVED
Go to solution
Telmah
Occasional Advisor

Microserver G8 + ESXi +AHCI = some problems

Hi!

 

I have a Microserver G8 with latest HP ESXi image stalled on SD card.

And following problem was found:

If in BIOS settings switch to AHCI usage - on every ESXi reboot disk disappears from ESXi server and every time must be readied - it can be done without any problems - and its working until next ESXi reboot.

If single HDD installed and used as RAID0 array via B120i - everything is OK in ESXi - disk are not disappears from ESXi after reboot

2 REPLIES 2
Jimmy Vance
Honored Contributor

Re: Microserver G8 + ESXi +AHCI = some problems


Telmah wrote:

Hi!

 

I have a Microserver G8 with latest HP ESXi image stalled on SD card.

And following problem was found:

If in BIOS settings switch to AHCI usage - on every ESXi reboot disk disappears from ESXi server and every time must be readied - it can be done without any problems - and its working until next ESXi reboot.

If single HDD installed and used as RAID0 array via B120i - everything is OK in ESXi - disk are not disappears from ESXi after reboot


When you have the SD card in the system without any othe drives, it will report as being /dev/sda. As you start adding hard drives, the device name of the SD card will increment. If you have 2 drives, the SD card would show as /dev/sdc, and if you had 4 drives, the SD card would report as /dev/sde. I don't work with VMware often, but you need to have VMware and the bootloader use some type of label to keep the device names consistent.

 

No support by private messages. Please ask the forum! 
Telmah
Occasional Advisor
Solution

Re: Microserver G8 + ESXi +AHCI = some problems

Yahoooo, problem was solved... Looks like once created, storage signature was assigned to RAID device, not to AHCI. So solution was very simple - just answer "Assign new signature" instead of  "Keep the existing signature" while (re)adding datastore back to host.