ProLiant Servers - Netservers

Microserver N40L can't flash to latest BMC firmware;

Occasional Contributor

Microserver N40L can't flash to latest BMC firmware;

I have a ProLiant Microserver N40L (G7) running Windows Server 2008 R2. There is a HP ProLiant MicroServer Remote Access Card in it running firmware version 1.2. I downloaded the iLO update to version 1.3 from this URL. Apparently have two options to install the update:

First I can upload the image to the iLO card using the web interface. When I try that and select the .bin file for the update, I am presented with an "Uploading" page that stays up indefinitely. It never goes away. I assume that the update process will not work, but have no error messages to troubleshoot from.

Second, I can use the firmware from the operating system itself using the socflash utility. I've placed the 64-bit driver and all.1.3.bin file in the same folder and then ran update.bat file at an elevated command prompt as per the instructions, however I'm now receiving the error C:\Users\goodshepherd\Downloads\BMC_FW_Version1.3_12_07_2012\socflash\Windows>so



socflash if=all.1.3.bin gpio_b=c40 gpio_f=c41
ASPEED SOC Flash Utility v.1.03.02
[Error] Cannot load Windows WDM Driver Properly!!
[Info] Please make sure the driver signature enforcement had been disabled in Windows 2008 x64

However, driver signature enforcement is disabled as witnessed by the following:


bcdedit.exe /set nointegritychecks ON 
nointegritychecks       Yes

So there are no driver integrity checks being done. I've rebooted to make sure that the option stays. I still cannot run the firmware update because of the same error at the command prompt and the web interface will never complete the upload of the image file for the update.


Any way I can update the remote access card to version 1.3 firmware?



P.S. This thread has been moevd from ProLiant Servers (ML,DL,SL) to ProLiant Servers - Netservers. - Hp Forum Moderator





Occasional Contributor

Re: Microserver N40L can't flash to latest BMC firmware;

For good measure I downloaded the latest September 2013 Proliant Support Pack and booted the MicroServer into it. I chose "Automatic Firmware Update" and yet the iLO was not updated.


I tried once again, but this time chose the interactive firmware update option. At the end of adding a repo and scanning for updates, there were none presented. Apparently it thinks that I've installed all applicable updates. I know I thoroughly updated all drivers and firmwares that I was aware of from within Windows, but I know that the iLO remains to be updated from 1.2 to 1.3. Unless the PSP does not have updated for iLO.


Strange. I just want to upgrade the iLO's firmware from 1.2 to 1.3 to stay up to date, but this is becoming increasingly perplexing.